View Full Version : G75vx soft bricked. Please help.

07-26-2015, 02:36 PM
Okay so after windows freezing randomly, I shut down my g75vx and turned back on (holding Power button) and now screen won't turn on, keyboard lights up and off, cd drive makes a noise and that's it... Power lights stay on aswell.

I was using a modded bios, which was working while uefi was on (was using this bios for 5 hours before freeze)

If any other info is needed to help me please let me know..

I have tryed to use the ctrl+home.. Nothing happens.. Unless I am doing something wrong?

Any help will be greatly appreciated.

07-26-2015, 04:22 PM
Can anyone assist me please?

07-27-2015, 04:30 PM

Sorry to hear the system isn't working better. Saw your PM, but thought it may be better to discuss on the forums to get more suggestions.

Anyway, since you were not actually flashing the bios when the system stopped working, would suggest going through standard troubleshooting (easier things that you can try on your end like connecting an external monitor, running without the battery, unplugging the hard drive, removing extra memory sticks and installing modules one at a time in different slots, etc.) since the problem could really be caused by something else.

If you didn't already know, you can also connect your hard drive to another computer with an external USB hard drive adapter if there is data you need to get to right away.

Anyway, let us know if you would like to do more troubleshooting (and let us know what else you've tried?), but it looks like you found some information about the ctrl+home bios recovery method at the post #32 below which does not always work and may not be able to help in this case.

If it's not too much trouble, probably worth a try though.
I've only tried it on the G75VW model and was able to get it to work with a functioning G75VW unit using the G75VW.bin file on the hard drive (not a USB drive which may or may not work?), but the procedure should be similar for the G75VX although you want to have the G75VX.bin (bios) file on your hard drive for your G75VX model, of course.
Also, the ctrl+home procedure didn't seem to work with the newer G75VW bios versions when I tried it (it's probably safer to use the original G75VX.bin file that came with the system if you can find it, otherwise try to rename the unzipped bios file for your G75VX model to G75VX.bin), so would also suggest trying older G75VX bios files (renamed to G75VX.bin on your hard drive C: drive) and not just the newest.
Hopefully it will not be too difficult to get the G75VX.bin file to a hard drive 'C: drive', but if others have been able to get it to work from a USB drive, would be great if they could let us know.


Good luck and feel free to discuss!