View Full Version : G751JT Windows 10 upgrade FAILED

07-29-2015, 05:23 PM
I have a virtually brand new (1 week old) G751JT here & just tried upgrading to Windows 10. Unfortunately, it failed with what looks like a storage driver problem. Anyone else seen this issue? Mine's a UK laptop if that makes any difference. Cheers.

07-29-2015, 05:31 PM
Can you be more specific? Did you follow my guide or did you just let it run its natural upgrade? Have you changed any hardware or drives on the 751?

07-29-2015, 05:43 PM
Hi. I just let Windows do it's natural upgrade & it crapped out with an error message that looked like a storage driver thing. Once I take a backup I'll try again and take a pic of the error (it doesn't stay on screen for long). No hardware changes on the laptop. Have only installed Firefox, Steam and some mapping software.

07-29-2015, 05:59 PM
Wow, I thought I'd try again and Windows update is insisting on downloading the whole freakin' 2.7GB kit again. Nice one, MS.

07-30-2015, 11:49 AM
Here's a screenshot of the error. After some research I've updated to the latest Intel Rapid Storage driver & will try again (after downloading the kit yet again, sigh).


07-30-2015, 02:01 PM
Try updating your Intel storage drivers and trying again.


Here is the DL link: http://downloadmirror.intel.com/25091/eng/SetupRST.exe

07-30-2015, 02:17 PM
are you overclocking your system in anyway?

07-30-2015, 07:26 PM
That same error happened to me. I made sure there were no updates going on in the background, turned off my wifi and antivirus, and windows 10 installed just fine after that