View Full Version : G771JM, Win 10 Upgrade Woes

08-04-2015, 05:55 PM
Brand new laptop.. about 3 hours old (All I did was do the initial windows 8.1 setup, and login), then I started the windows 10 upgrade.. That took all night, and when I woke up. the track pad no longer worked. After about 20 min of messing around, i found that the elise application had been disabled, so I enabled it.. Voila.. track pad... but still no way to click on anything.

Im going to revert back to windows 8.1, get access to all of my peripherals, and download all of the latest updates from asus, this way everything should work from the get go when I do the windows 10 upgrade again... anyone else have this issue?

this is a FREAKIN great laptop for my purposes :)

08-04-2015, 06:00 PM
You need to install the drivers after the upgrade not before most will get overwritten i would suggest a clean install and using drivers from manufacturers of the hardware not asus

08-04-2015, 08:12 PM
I understand that, how ever, If I download all of the drivers before I do the update, save them to my USB, I can install them ASAP without the absolute need of the track pad. rather then scrolling and tabbing around a webpage post install to find what I need then.