PDA

View Full Version : G55v Keyboard trouble after dissassemble to clean.



h3nrik
08-05-2015, 09:13 PM
Edit: Forgot to put g55v in the title >_>
Greetings kind users of this homepage!
Me and my friend thought it would be a good idea to open up his laptop, g55v, to get rid of some dust since I did the very same with
my g74s and got really good resulst despite the mousepad buttons doesnt work anymore.
Anyhow, after we it got cleaned and assembled some keys on the keyboard, G, E , 5, num lock, scroll lock, etc didn't respond anymore.
So any tips on how to solve it?
We've tried to reconnect the ribbon cables which is located under the keypad but with no good results.
Is there some way to check if they need to be repaired or fixed.
Thanks in advance.
/Henrik

InfernoStorm
08-06-2015, 08:20 AM
Use alcohol and clean the tips of the ribbon and make sure the ribbon isn't bent. Same exact thing happened to me and was driving me nuts. I used alcohol to clean the tips and reconnected it and the issue was fixed.

There's a chance it's not a contact issue but rather the ribbon is damaged.

h3nrik
08-06-2015, 07:53 PM
Thanks for the tip. But it did not work for us.
We found the problem, its a cable with "G55VW KB PCS CABLE 1414-076N000 LUXSHARE-ICT 120520" on it.
One of the pins on that cable was looking quite odd so it might be the problem?
50894
50895
50896

Thanks in advance.

InfernoStorm
08-07-2015, 01:04 AM
That definitely looks like the problem, even a tiny bit of the connection part is damaged may cause problems.

h3nrik
08-08-2015, 12:12 PM
Yeah the keys that doesnt work are probably connected to that pin.
Anyone happens to know where to get something to replace it with?

InfernoStorm
08-16-2015, 05:39 AM
Sorry for the late reply, you could try using a very thin soldering tip and get some flux to the part of the connection that's missing. I think it's just poor connection on that part that's causing the issue.