PDA

View Full Version : G750JX Backlight Keyboard not working



QuellaVolpe
08-07-2015, 07:30 PM
Title says it all but here's a more detailed explaination of what I did:
I just got my pc back from an RMA and I found that they formatted it. No big deal: did ALL the updates, reinstalled 8.1, updated everything again, then I go on and download BIOS 209 from the Asus siteand Flash it in with Winflash. Everything went well except for one thing: the keyboard doesn't light up. At all. And if I press Fn+F4 (or F3) the LED brightness doesn't even show up (for you guys that know how it works it has 3 levels and it should always say at what level of brightness your keyboard is set).

Once I noticed that I tried EVERY ATK driver currently on the site but still it doesn't work, it's the one and only thing that is not working, everything else is perfect, even the other Fn +Fwhatever functions work. They keyboard is the only one. Anyone who can help? More details will be given if asked.

QuellaVolpe
08-08-2015, 01:56 AM
If it is of any help: just did a factory reset: didn't solve the problem. Starting to think this is a hardware related problem

FalconFX
08-08-2015, 09:29 AM
I dont know how to fix it, but its most likely from the update you did to the bios, so if possible try to revert back to the version you had :)

QuellaVolpe
08-08-2015, 09:48 AM
Maybe, trying everything out right now ;) I just realized I didn't even install java, dunno if it's somehow related but... Yeah xD

Darnassus
08-08-2015, 11:09 AM
Lol they really need to take down BIOS 209 or update it to say "If you're on 208 do not upgrade" because so many people come back with problems..

Edit: You said RMA but what exactly did they do? If they dismantled the unit, there's a good chance the shoddy tech guy forgot to seat the cable that handles the LEDs to the board.

The keyboard has three ribbons if I remember correctly. It's been a while.

QuellaVolpe
08-08-2015, 11:13 AM
I had burnt pixels on the screen and the left fan making a weird noise, nothing keyboard related but yes, the fan problem definitely needs a dismsntle to fix. It doesn't make sense though because the caps lockcLED wouldn't turn on if it was hardware related. Plus if it was hardware related it should show me the little indicator with the 3 levels of brightness, but that doesn't show up either.

EDIT: I'm re-installing 8.1 now after the factory reset, still haven't touched the drivers or the bios, just did the basic obligatory updates. The factory reset did not prove useful btw. Every fn combination works like a charm except for fn+f3 and fn+f4 :/ just in case: the f3 and f4 keys are not broken, they do work fine