PDA

View Full Version : Windows 10 & Rampage 4 Formula eSATA Problems



shimeng
08-08-2015, 07:34 AM
Hi,

Upgraded to Win10 from Win7 Home Premium 64bit via reservation and now my external eSATA HDD enclosure cannot be detected.

My SSD boot drive currently runs off an internal SATA port driven by the embedded Asmedia controller - that works fine.
The external HDD is hooked up to the eSATA port which is also driven by the Asmedia controller, so I can't understand why it's not working.

Both SSD and external HDD are detected in the BIOS - they are reported once each during POST so I think there are 2 separate Asmedia controllers onboard. Still no reason why one controller will work and the other will not.

Doesn't seem to be a driver issue - both worked fine with the standard Windows AHCI driver when it was running Win7 and I can see in the Win10 Device Manager that the stock Windows drivers are installed.

Anyone else have this problem?

I will try to move the SSD boot drive to the internal Intel 6G SATA port (yes, I know it should have been that way to begin with) and see if that works.

Finally, I do NOT want to install the Assmedia drivers - I did that when I first got the Rumpage Formula and Windows suddenly reported data inconsistencies with an eSATA WD Studio2 that I used to store my family photos and videos. It did a scan and deleted a lot of files. Turns out there was nothing wrong with the WD Studio2 - it worked fine after I reverted back to the standard Windows AHCI driver but by then a lot files were permanently lost.

Thanks for reading my rant.

Ivan