View Full Version : G551 - Lower framerate over time

08-12-2015, 02:03 PM
Hello all, this is my first post and it is nice to meet you all :D I am having performance problems with my G551laptop. For just about any games, the framerate will plunge after about 20 minutes of playing. I have tried games that are quiet old now such as Sleeping Dogs and Crysis 2 (which are on Steam) and The Witcher 3 (DRM-free GOG version).

When I say lower framerate, I mean I go back to the exact same area I was in and the framerate is lower to the point the game becomes unplayable. Sometimes the problem can be so evident that while standing still (without anything happening on screen) the framerate can continue to drop.

My specs are as follows:

Intel Core i7 4720HQ 2.6GHz 6Mb

Does this have anything to do with cooling? Does anybody have the same problem as I do?

Thank you in advance for your help :D

08-13-2015, 02:27 AM
You must connect it to the charger while playing other wise it will not work with best framerate.

08-13-2015, 08:25 AM
Thank you for your reply!

Indeed, I always connect the laptop to a power source while playing, and switch the power setting to High Performance. I get very good framerates at first, and then it starts going downhill.

Please help me if you have similar issues before!

08-13-2015, 09:03 AM
This is usually related to thermal throttling issues. When your CPU/GPU hit 74 degrees, if I recall correctly, your components will begin to limit their performance as a way to prevent damage. Dig around these forums, I read a topic recently about this issue on how to raise the thermal throttling limit.

On other machines such as the G751 series the thermal throttling is not set artifically by ASUS - components start downscaling performance at around 90-95 degrees.

08-13-2015, 11:37 AM
I see. So the limit has been set by the manufacturer? It does explain how I only play for less than half an hour and the framerate has already plummeted. Thank you, I shall try looking for a solution now :D

08-16-2015, 07:02 PM
maybe u can change to high performance energy mode whole u r playing