PDA

View Full Version : Webcam Help - Not working after Windows 10 upgrade - ROG G74Sx



Daitzen
08-13-2015, 11:45 AM
Hi everyone,

Hoping for some help and sorry if I put this in the wrong section.

I upgraded from Windows 7 to 10 recently and I've been using it for the past 3 days and its been great.
No problems whatsoever.

However, today I attempted to make a video Skype call and realised that it doesn't recognise my webcam anymore.
Under the device manager ASUS USB 2.0 webcam is there with a yellow error symbol.
I uninstalled the device and scanned for hardware changes hoping it would assign a working generic driver and that didn't work.

I figured I could just reinstall the ASUS drivers and see what happens but they're not listed under the G74Sx driver section.

Anyone have any suggestions?

Almighty1
08-14-2015, 08:04 AM
I have the G74SX-3DE and my webcam works fine.

In Device Manager under Imaging Devices, it's listed as:
USB2.0 UVC 1M WebCam

with the driver provided by Windows 10 as the driver info says:
USB2.0 UVC 1M WebCam
Driver Provider: Microsoft
Driver Date: 06/26/2006
Driver Version: 10.0.10240.16384
Digital Signer: Microsoft Windows

On the ASUS website:
http://support.asus.com/download.aspx?SLanguage=en&p=3&s=336&m=G74Sx&os=&hashedid=LUFmeP8fwFruEdH7

You first should try uninstalling the Webcam and then reboot to see if it will detect on it's own.

Under Utilities, grab the ASUS FaceLogon Utility V1.0.0013

You need the following under Utilities after the camera works:
ASUS Virtual Camera Utility (The Camera driver must be installed.) v1.0.25

It appears the webcam just uses Microsoft Windows supplied drivers...

http://rog.asus.com/forum/showthread.php?5785-G74SX-Webcam-Driver

Daitzen
08-18-2015, 04:06 AM
Sorry for the late reply.
For whatever reason my webcam doesn't seem to use the supplied drivers given by Windows 10.
I downloaded the logon utility and virtual camera utility and those didn't help either.
As I said earlier I did try uninstalling and rebooting but that also didn't work :(

Still looks like this to me.

51144

Almighty1
08-18-2015, 04:56 AM
Have you tried manually updating the drivers and choose from the list instead?

Daitzen
08-28-2015, 09:15 PM
Hey,

Yeah I've tried that and it doesn't work either.
This week I installed every possible driver provided by ASUS (Bison, Chicony, Azureware,etc) and none of it helped.
Guess I'll just have to hope that Windows updates will fix the problem.

Maybe there are differences between your model and the G74SX-XA1 that I have.

Here's the error as system information has it:

51387

I've pretty much given up at this point :(

Almighty1
08-29-2015, 09:34 PM
You're right, seems like you have a entire different webcam from the device ID compared to the G74SX-3DE (3D LCD display) that I have...

51395

Almighty1
08-29-2015, 09:41 PM
Try this:
http://drivers.awdit.com/vid_1bcf/usb-enhet-sammansatt-3/

Basically, you need to search for "VID_1BCF&PID_2885"

Daitzen
08-30-2015, 11:11 PM
I ended up on that page during my search.
They have a long list of drivers that would supposedly work with my webcam but no actual download links.
Unless there's something I'm not seeing.
All the download options say coming soon.

Almighty1
08-31-2015, 05:35 PM
You're right about the download options saying coming soon. Other searches will just say it's for the G55VW. However, when going to ASUS's G55VW, regardless what Windows version for the OS one chooses, there are no webcam drivers listed.

Almighty1
09-01-2015, 09:40 PM
You might try reading and posting here:
http://www.tenforums.com/drivers-hardware/19932-webcam-not-working-after-upgrade-windows-10-a.html