PDA

View Full Version : Wi-Fi ping spikes on G771JW



Kreedny
08-17-2015, 09:10 PM
Two weeks ago I bought a new G771JW and installed Windows 8.1 on it, after which I upgraded to Windows 10. I must mention that I installed all the drivers from the CD. I usually play World of Warcraft and League of Legends/DotA so I decided to install those first. In WoW everything moves fine on Ultra (although I had to disable the anti-aliasing and MSAA because from 5 to 5 seconds it was moving in slow motion), in LoL or DotA I have constant ping spikes from 40 to 120+. After some tests in which I went to some friends in order to check if it was my router's fault I discovered that it's actually the laptop's connection to the router(s) at fault. I have no idea regarding how to solve this issue, therefore I would greatly appreciate some help.

lmujaj
08-17-2015, 10:46 PM
hmmm ive searched in google about this problem to fix mine , ive fixed by disabling scanning after you connect to wifi , the scanning after you connect cause the lagg...
its a command in regedit you've to add ...(ill search after i got home again )

1st try to unistal Asus Rog 1st and Gaming center , i dont know the correct names .. you gona have some improvements ...

Kreedny
08-18-2015, 06:29 PM
Did you find the right names? It would help me a great deal as I wasn't able to find the things you mentioned.

lmujaj
08-18-2015, 07:02 PM
After doing a bit of research, the ping spikes are caused when the wireless card scans for networks. I was actually able to reproduce the issue and can confirm this. You can do so yourself.

Go to cmd, type ping www.google.com -t


If you're on Windows 8 or 8.1, all you need to do is access the wireless network list by clicking on the wireless icon on the bottom right and it will automatically refresh. For those on Windows 7, click the wireless icon on the bottom right and click on the refresh button next to your connected network. As you are doing this, you'll notice that the ping counter on the command prompt will spike up. I thought it was an issue with the card as well and I was wondering about getting a replacement as well. It can be ridiculously annoying for gaming. It seems as though Windows likes to re scan for networks periodically causing random lag spikes. If there was a way to stop scanning while you're connected to a network, that would be great.


UPDATE: Oh boy, I was able to find a solution. It involves using the Registry Editor. Be careful not to change anything else except for the things that are listed.


1. Open Registry Editor (Windows 8/8.1, right click where Start button was, click Run, type regedit. Windows 7, click Start, click Run, type regedit)

2. Head to 'HKEY_LOCAL_MACHINE \ System\ CurrentControlSet \ Control \ Class \ {4d36e972-e325-11ce-bfc1-08002be10318} [Be sure to expand the 4d36e.... folder]

3. Inside will be a number of folders named 0000, 0001, 0002, etc. Look through all these folders until you get one that says Intel(R) Dual Band Wireless-AC 7260 in the registry.

4. Once the device has been found, search for a value called ScanWhenAssociated.

5. If you see this value, set it to 0 on hexadecimal. If you don't see the value, click edit from the top, select new, and click DWORD (32-bit) value. Rename this value to ScanWhenAssociated (exactly as shown). Make sure this value is set to 0 on hexadecimal.

6. Restart the computer. This is important. The changes won't take effect unless you do

------------
IVE COPY PASTE THIS "FIX"

same sulution explained also here
https://forums.lenovo.com/t5/Windows-8-and-8-1/SOLUTION-latency-spikes-and-network-unstability-on-Intel-WLAN/td-p/1461487

Kreedny
08-20-2015, 07:09 PM
Thanks! It works perfectly right now!

bruh117
09-29-2015, 03:18 AM
Hi guys! I have the same issue. I followed all the steps but I cannot find the folder which contains the scan when associated. The most that I have reached was: in folder 0002 i found in the rgistry editor Intel (R) Dual Band Wireless-AC 7260. Do i change this one to scanwhen associated? Please guide me. I dont know about this kind of stuffs. Thank you for your help.