PDA

View Full Version : G751JY Wifi not working on Windows 10



Gus__Fring
08-18-2015, 06:41 PM
Hi

I've recently upgraded to Windows 10, and my wifi connection has stopped working. I have uninstalled the driver (with the remove driver option ticked), installed the new drivers from intel's site, and nothing. I've also done a clean Windows 10 install and then repeated the above steps, but it's still not working. The laptop appears to connect to the router, but most of the time it says 'limited connectivity' and I can't connect to any sites. It's very frustrating! All my other devices work fine (as did this laptop prior to Win 10)

Does anyone have any suggestions please?

Many thanks for any help

thewebkid
08-25-2015, 12:36 AM
I am having the exact same issue. Everything was fine with Windows 8/8.1. Now I am unable to connect wirelessly.

aeolisio
08-25-2015, 10:35 AM
Try an older driver and reset/check your router settings.

kingjezdi
08-25-2015, 06:16 PM
try this :
http://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=startdown&id=1704

NeoBeum
08-26-2015, 11:46 AM
Which build Windows 10 did you clean install?

Tekolar
08-27-2015, 02:39 PM
Since Windows 10 I also have to restart once or twice before I get a wifi connection. Automatic problem solving of Windows says wifi doesn't have a valid IP configuration. Sometimes it can solve it sometimes not. Although it also might be the router itself since I don't have access to it cause im in a kind of hotel atm.

joshindaphils
08-27-2015, 03:03 PM
I had a simular issue with Win8.1. I could set a static IP and everything worked, I just could not lease an IP.

I uninstalled Game First then everything worked as anticipated.

If you have Game First installed try uninstalling it and see if your issue clears up.

Tekolar
08-27-2015, 03:45 PM
I'll try that, thanks. Never used it anyway and I just noticed that it does start but freeze completely until it gets closed.

molokow
08-28-2015, 11:31 AM
Mate, I am using Windows 8.1 pro now. I had nothing but wifi issues with windows 10

Tekolar
09-07-2015, 09:22 AM
Btw, thanks. It seems it really was Game First causing the issues for me.