View Full Version : X-fi mb3 "No supported audio device available" after win refresh , but worked before?

08-26-2015, 08:19 AM
I bought Creatives X-fi mb3 soft in may 2015 installed it and it worked untill yesterday when I did a refresh of windows on my g751jy. Refresh uninstalled all software. I thought, no problem, I'll reinstall it right? Wrong! Reinstalled X-fi mb3 and it spew "There is no supported audio device available" window! What?

It have worked like 2 hours before the refresh. What the..

I searched the net with uncle google and found a tons of people having the same problem. They install a mobo with boundled x-fi mb3 for the first time, install mb3 and "There is no supported audio device available" does not work out of the box?!? And no solution other than reinstall audio drivers and mb3.
I did reinstall realtek hd audio drivers and mb3, this is what creative support would come up with in they most glorious moment, but it does not do any good. I still get "There is no supported audio device available".

Can anyone help me?