PDA

View Full Version : G551jm, No SOUND on TV via HDMI



foxxx46
08-26-2015, 09:05 AM
I own G551jm and when i connect computer via HDMI to TV the sound is playing on computers speakers not on TV's, I've tried to change it in playback devices tab but it says that HDMI is not plugged in. In nvidia control panel i dont have an option like this http://gamingwithscissors.com/wp-content/uploads/2012/05/Nvidia_Settings.png but only 3D settings. Does anyone know the solution? Thanks.:)

clockworksatan
08-26-2015, 10:22 AM
Right-click on the speaker icon in the system tray (bottom right of screen) and select Playback Devices, you might have an option on here for playing back via HDMI.

joshindaphils
08-26-2015, 11:11 AM
Right-click on the speaker icon in the system tray (bottom right of screen) and select Playback Devices, you might have an option on here for playing back via HDMI.

He mentioned that he doesn't have the option in the playback tab ;)

Foxx46,

Try to do a clean driver install (choose custom when reinstalling the driver) Make sure you have the nVidia HD audio drivers selected during the install.

If this adds the option back to the playback tab for you, then you will have to ensure that your TV as the default playback device.

clockworksatan
08-26-2015, 11:40 AM
He mentioned that he doesn't have the option in the playback tab ;)

D'oh! I should read things more closely, lol!

foxxx46
08-28-2015, 06:49 PM
Tmx for replying :) i tried to do clean instal of nvidia drivers but i have no hd audio option where you choose what to instal. I dont know if is problem since windows 10 because i didnt tried on win 8.1...

bartat404
08-29-2015, 09:39 PM
This laptop has NVIDIA Optimus, so the HDMI isn't even being powered by the NVIDIA GPU, but instead the Intel HD Graphics. To get the audio working properly on the laptop, install the Intel HD Graphics drivers from the ASUS website for your laptop.

(You may have to install the one or Windows 8.1, as there isn't a Win10 specific version available, but it will work just as well.)

foxxx46
08-30-2015, 02:22 PM
This laptop has NVIDIA Optimus, so the HDMI isn't even being powered by the NVIDIA GPU, but instead the Intel HD Graphics. To get the audio working properly on the laptop, install the Intel HD Graphics drivers from the ASUS website for your laptop.

(You may have to install the one or Windows 8.1, as there isn't a Win10 specific version available, but it will work just as well.)

I have installed Intel HD graphics driver from ASUS website and there is no audio option whatsoever. Playback settings looks like this.
https://i.gyazo.com/b64011cdc6b572419ae651c5c418d4f3.png

bartat404
08-31-2015, 01:56 PM
I have installed Intel HD graphics driver from ASUS website and there is no audio option whatsoever. Playback settings looks like this.
https://i.gyazo.com/b64011cdc6b572419ae651c5c418d4f3.png

See the HDMI reading as "High Definition Audio Device" It's using the wrong driver.

Use Device Manager and manually switch the driver to the Intel one that was installed with the Intel GPU drivers.