PDA

View Full Version : G46VW HDD to SSD replacement: SSD can only use SATA 1.5?



Hunter23
08-28-2015, 10:46 PM
Hi guys,
I've finally replaced the pretty crappy hard drive in my G47VW to a Samsung 850 Evo 1Tb. After transferring most of my files over, I realized that Samsung Magician is saying that it's using SATA 1.5, which is not optimal.
I looked for answers both on these forums and the general web, but I've come across two different solutions that I'm not entirely sure may work:
1. In the BIOS, Disable Fastboot + Disable Secure Boot + Enable CSM
2. Uninstall the Intel Rapid Storage Technology driver and use the Windows AHCI driver.

From what I've read, the G46VW uses either a SATA 2 or SATA 3 port, but I'm not sure if my model only has a SATA 1 port, there's something sfotware/driver-wsie I can do to fix this.

Any help is greatly appreciated!

Clintlgm
08-29-2015, 02:06 PM
Hi guys,
I've finally replaced the pretty crappy hard drive in my G47VW to a Samsung 850 Evo 1Tb. After transferring most of my files over, I realized that Samsung Magician is saying that it's using SATA 1.5, which is not optimal.
I looked for answers both on these forums and the general web, but I've come across two different solutions that I'm not entirely sure may work:
1. In the BIOS, Disable Fastboot + Disable Secure Boot + Enable CSM
2. Uninstall the Intel Rapid Storage Technology driver and use the Windows AHCI driver.

From what I've read, the G46VW uses either a SATA 2 or SATA 3 port, but I'm not sure if my model only has a SATA 1 port, there's something sfotware/driver-wsie I can do to fix this.

Any help is greatly appreciated!

Well to start with turning off secure boot and fast boot will not change anything. Do you have 2 hard drive slots? the one that your original hard drive was in should be SATA 3 6GB I don't really remember what the G46 drives set up was but if your only getting SATA 1.5 out of the main hard drive bay you probably have a hardware problem.
You have Secure boot so that means your notebook came with windows 8? and you should be set up UEFI with disk GPT? CSM should be off. In windows you should be running the latest Chipset, IRST and IME drivers from Asus Support Downloads (http://support.asus.com/download/options.aspx?SLanguage=en&type=1) You really don't want to run your SSD in Legacy mode.

Hunter23
08-29-2015, 05:06 PM
Interestingly enough, I found a tutorial explaining Intel Rapid Storage drivers don't have to be uninstalled, you can simply tell the port to use the default Windows AHCI drivers.
After doing that, I'm not getting SATA 3 6GB speeds.
The explanation I found is on this (http://answers.microsoft.com/en-us/windows/wiki/windows_7-hardware/uninstalling-the-intelr-rapid-storage-technology/e3c4b6d6-56ba-4ac5-be50-89843c9d9b22) page.

C4RN1
08-30-2015, 07:47 PM
I'm getting Sata 3 speeds and HWinfo64/CrystalDisk will confirm

51402

51403

51404

You can run a simple ssd test to see where you're at.

51405

This is about right for my ssd's advertised performance

Max Sequential Read - Up to 550 MBps
Max Sequential Write - Up to 470 MB/s

I have attached the program below, take a screenshot of your results.

51406


Do you have 2 hard drive slots? the one that your original hard drive was in should be SATA 3 6GB I don't really remember what the G46 drives set up was but if your only getting SATA 1.5 out of the main hard drive bay you probably have a hardware problem.


Clint, the G46vw has only one hdd bay located in the middle of the machine.

http://i145.photobucket.com/albums/r217/Carnifreekshow/20150416_184441_zpsf6sgenwp.jpg

On the bottom side of the motherboard we have a half size msata slot, though most of the community has used full sized msata cards by securing it with double sided tape.

Hunter23
08-30-2015, 09:23 PM
While following the tutorial I posted, Intel RST decided to reinstall itself after I restarted to install some Windows updates, and I realize what the issue is.
After setting the driver to the Standard AHCI driver, Device Manager won't show anything the hidden "Non Plug and Play drivers" section until restarting, at which point anything in that section is part of Intel RST. I'm going to uninstall these as well and hopefully nothing reverts back.

Clintlgm
09-01-2015, 09:59 PM
C4RN1 that's for the detail, Hunter23 glad you solved you issue.