PDA

View Full Version : Backlight Issues



Ripley
12-18-2011, 10:42 AM
Hey guys,
I own a G53 model laptop and have had it for about a month now. I recently decided to attempt the backlight mod where you place a piece of coloured film between the keys and the leds as outlined in this video (http://www.youtube.com/watch?v=rklOixPa_ns)

Unfortunately I was unsuccessful and although my keyboard does work, it no longer lights up. I have tried to reinstall the atk drivers but to no avail :(

any suggestions would be greatly appreciated,
Thanks,
Frank :cool:

thesilent85
12-18-2011, 12:10 PM
I think you ripped the cables or the wires connecting the light to the keyboard. Check with Asus warranty to fix it.

fuzon1337
12-18-2011, 12:12 PM
Hi

When you did take it apart, are you sure no cables in the KB didn't break off or something?
Perhaps you placed the cable for the backlight wrong when you inserted it back in? (the "gold" have to face up to the KB and not down to MB)

Ripley
12-18-2011, 10:05 PM
ahh, so the gold connectors on the keyboard power cable must face towards the keyboard. I put them facing away and towards the motherboard. I will switch it around and post the results

fuzon1337
12-18-2011, 10:13 PM
In this Guide (http://forum.notebookreview.com/asus-gaming-notebook-forum/533714-guide-disassembling-g53jw-installing-second-hard-drive.html) on picture 3. you can see how it's ment to be :)

It's easy to set those cable in the wrong way, I'm having trouble that the backlight don't want to turn on at all, and haven't worked when I bought the notebook :(

I hope this fixes your problem :D

Ripley
12-18-2011, 10:22 PM
thanks heaps for your suggestion fuzon, it works now! the backlighting looks really sick! I hope your backlight issue is fixed as well in the near future

fuzon1337
12-18-2011, 10:38 PM
Good! :D Which colour film did you use? :)

I also, it already have been into fix one time for the same issue, but came out again without the problem fixed, gosh! -.-
So after new year I'm going to send it in again, and hopefully it will work when I get it back :D :P