PDA

View Full Version : Disable Touch Pad for G750JM with Windows 10



Wabie
09-05-2015, 05:19 PM
Hello I have recently purchased a G750JM laptop and everything runs smoothly and fast on it except I can't disable my touch pad,
windows 10 is my operating system. I have tried fn and f9 together and still nothing, I am finding it very annoying when I play games that sometimes my hand messes up my aim when it touches the touch pad. If anyone can help me they can have 1000 hugs from me. :D

GottiBoi55
09-05-2015, 09:25 PM
Hello I have recently purchased a G750JM laptop and everything runs smoothly and fast on it except I can't disable my touch pad,
windows 10 is my operating system. I have tried fn and f9 together and still nothing, I am finding it very annoying when I play games that sometimes my hand messes up my aim when it touches the touch pad. If anyone can help me they can have 1000 hugs from me. :D

Hi Wabie, and welcome to the ROG forum.

Try this driver package to repair your touchpad problem>>>>>>Elantech TouchPad (http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/Touchpad/Touchpad_Elantech_Win81_64_VER115121.zip)
It's for Windows 8.1, but should work just fine.
There's no Windows 10 driver available at the moment for the Elantech TouchPad. (Works just fine on my Windows 10 upgrade)
You can also set touchpad settings in the "Asus Smart Gesture" console as pictured below, go to the last tab "Mouse Detection" and check the box to disable touchpad on mouse detection.

Hopefully this will fix your issue my friend.
Good luck, and good gaming!

(http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/Touchpad/Touchpad_Elantech_Win81_64_VER115121.zip)

Wulff
09-11-2015, 12:41 PM
in windows 10 click the touchpad icon on your taskbar on the right, there is that button for mouse detection wich allows you to disbale the touchpad if an external mouse is connected