PDA

View Full Version : Failed Bios Flash on N61JQ



KindlyKickRocks
12-19-2011, 03:14 AM
Hi,

This thread is part question, part record for posterity on the N61JQ. Back story is long but 1-2 years ago, I RMA'd my laptop due to it being DOA, issues with corrupted boot and corrupted recovery drive. Ever since I got it back, it would BSOD at least once a week, at most 3-4 times a day and I was 100% sure it was due to the video card. But I put off fixing it because for the most part it worked and I could not do without my laptop for extended time periods. Recently, I got fed up with it and decided to flash the BIOS and redo the drivers again. Starting with the BIOS flash.

Needless to say it was bricked, but I found out my BIOS was v202 (which bolstered my idea that flashing to v212 was the correct action) and that the flash process completed, but it just died during reboot, with the light scroll still active.

After some time with customer support, I've got it RMA'd and it's in transit. However I received a communication where they informed me that if the technicians deem it Customer Induced Damage, they will charge me. But numerous threads tell me otherwise; my warranty should be valid in this case.

So is this standard procedure or am I about to get duped? Is there a way I can argue or demand they apply this to my warranty? Was I in the wrong? I mean the BIOS version was the lowest version and I was having functionality problems, BIOS and drivers must have been part of the reason. I just want them to figure out that damn blue screen issue.

Sorry I didn't mean to be so long winded, I'm just pouring my frustration into this post and hoping someone can help me out and maybe inform some future person with this issue.

Brightside
12-24-2011, 01:25 AM
Hi
if u get blue screen during the reboot after the system logo, u can do this steps and hope its help go to BIOS by turn ur laptop on and keep hitting F2 its will show BIOS screen up, now Select advanced – IDE – if u see it ENHANCED change it to Compatibility if its Compatibility change to ENHANCED then hit F10 and save. hope its will help. GoodLuck