PDA

View Full Version : G750j plugged In but not powering on



jivita
09-09-2015, 02:29 PM
hi,

i'm using my g750j since 2 years and it worked well al the time.
i'm using the notebook most time without the battery.

today i forgot my charger and used it with the battery. all fine. later, i released the battery and pluged in the charger and i tried to start the notebook again.
but it didn't do anything. i pressed the power button, but nothing happens. not light...nothing. i put the battery back in and the notebook starts. but now the battery is empty (it wasn't charged with th charger pluged in) and it didn't start.
i contacted the support and tried the hardware reset: release all plug and the battery, press the power button for 20-25 seconds, plug in the charger and press the power button again.
that didn't help.

i don't know, what i can do now?
there is no guarantee any more and the support told me, that i have to pay the repair.
my problem is, that i need to use my notebook for work and i wasn't able to make a fresh backup (last backup is 1 month old)...

is there anything i can do?

regards,
jivita

Maxter
09-09-2015, 06:10 PM
could be one of 2 things... one, your powerbrick is dead, or the other, the plug in the computer (at the Mobo level) is broken. All G750 and G751 use the same powersource. Try a friend's?
If no light on, then it's a mobo issue. If light comes on, then you need a new powerbrick (they run 80-120 dollars depending on the brand). According to BestBuy, the equivalent brick to the ASUS brand is a Delta Electronics, model ADP-180EB D. Output is 19V at 9.5A, which gives the same wattage as the original one.