PDA

View Full Version : Gl551jw won't start up?



Driqid
09-16-2015, 12:37 AM
Hey everyone,

My Gl551jw-ds71 Jude shipped in and it won't start up. It doesn't even make it to POST I believe.
The battery light is green and when I press the power button all the status lights turn on for a second before turning back on. There's also an extremely brief flash on the computer it seems.
I tried the method of unplugging the power source and battery and pressing he power button for 45 seconds and it didn't work.
Is there a throng else I could do before shipping it back? (I have homework that would be mot convenient to finish on it so I really don't want to keep waiting until I get a new laptop).

Any help is appreciated.

Gps3dx
09-16-2015, 01:18 PM
The short easy solution: if you said that you've just bought the item.... RETURN IT AT ONCE and demand you get a NEW item instead!

The long & advanced solution:
If you don't see ANYTHING on the screen ( after you've press the ON key ), i.e no logo, no text... means probably a HW problem as follows:
1. RAM cards - you should open the back door of the laptop, take the RAM cards out, clean the cards and the slots with alcohol (=ethanol), return everything to its place.
2. Try to power on without battery ) (while connected to AC power )
3. It might be also a BIOS ( aka UEFI ) problem.
Asus usually have some "CrashFree" feature to flash bios from USB even if the bios it self is corrupt. ( after boot, you usually see some message that says that the BIOS is corrupt ) I know this from my old ROG laptop.... See THIS THREAD (http://rog.asus.com/forum/showthread.php?17622-Had-a-bad-BIOS-flash-Read-this!) and THIS THREAD (https://rog.asus.com/forum/showthread.php?73346-Reviving-bricked-Asus-G55VW-bios-chip).
Its better if you contact asus support through their site to ask for the right combination of buttons & name of the "BIOS.rom" filename that should be found on a USB connected to the laptop ( fat32 formatted )