View Full Version : G74SX turning on, then down after 2 seconds

09-16-2015, 11:45 AM
Hi ROG Community,

I'm here to ask for help to everyone => I think my Asus died, let me introduce you to the facts :

- One morning, i had the magnificent idae to bring my G74SX laptop to wy workplace, it's a second hand laptop and it needed a little clean-up, as the holidays made time passing wayyyy longer than usual...
I opened up that son of a shrimp and found that there was more dust than i thought, so i blew compressed air inside of it and got a little cloud inside the IT which everyone liked soo much.

- After that clean-up, i turned the beast on again, the perfs were a bit better, i uninstalled few unused games/softs... and tidied-up all the docs in an external HDD.
This was so satisfying, i decided to do what i clearly regret today :

- I restarted the laptop, entered in BIOS and started looking after all options, modifying and trying to see what can it do (especially the power options, because i wanted to OC just a little my i7)
The thing is, it was a visit, i never meant to save all those options, but i did ! :(

Now :

When restarting after that Save, the laptop's On/Off Button is turning ON for 2 seconds, no display, no sound from the speakers, but i can hear the HDD turning then stopping after 2 sec.

What have i tried ?

I've tried to :

- Empty the static electricity that remained in the computer by pressing the On/Off Button during +2min (without AC and battery plugged)
- The magnet trick, to unlock the magnetic screen lock near the touchpad
- Removing the CMOS Flat Battery for 48 hours (i was away)

Now i'm starting to think that everything is over for my good old buddy G74SX, but i believe in your power, ROG Community !

Please... HELP ! I'll feedback as accurate as possible !

P.S : Ofc, my laptop isn't under warranty anymore

Regards to readers and contributors.

09-16-2015, 03:56 PM
Doesn't sound like the motherboard is dead, the bios is just set incorrectly.

Try this




On most laptops there's a way to reset the bios chip by shorting 2 pins and powering on the machine. You might be able to do this, though I don't think anyone has posted information about this for a G74sx.

09-17-2015, 07:12 AM
Hello C4RN1,

Thanks for your reply !
I saw this, but i directly forgot it because of the "Gain access to the SPI ROM" step haha

I'll try this and look for mobo specs for the G74SX about those 2 pins to shortcut.

Feedback's coming soon ;)

10-07-2015, 01:09 PM
Hello again !

I tried to get an ISP/SPI Programmer but didn't find any sooooo : does anybody have a documentation PDF or something like that where i will find informations on those Jumpers to Shortcut.
I tried again to reset the BIOS by removing the Battery and unpluging the connector related to the BIOS part but nothing moved.

Anyone have that precious doc ?


10-07-2015, 04:19 PM
Didn't find any?



Does this help?

10-12-2015, 09:34 AM

Thanks for supplying links, it helped me to understand which BP to use.

BUT, before purchasing anything (i'm not that confident with buying things i'll need only once) => Do you think that finding those hidden jumpers would help me resetting the BIOS for good ?
I feel like buying that BP should be the last thing to do (after having tested to shot-crcuit those jumpers) and i didn't find those ! :'(

Do you get my point of view ?

03-01-2016, 11:43 PM
Hi C4RN1,

I bought Bus Pirate, a SOIC 8 Pin Clip and fully dismounted my laptop annnnd facing and issue again, hope you'll be able to help :

Following these (https://rog.asus.com/forum/archive/index.php/t-24576.html) instructions, i'm now unable to WRITE, READ or ERASE any content on the MX25L3206E BIOS chip.

I've verified the following requisites :

- Power supply on the mainboard + VCC given by the Bus Pirate
- Pinouts are well connected (verified with BP, chip and SOIC datasheets)
- Firmware of the BP and the flashrom version

The error message displayed below is constantly appearing :

Probing for Generic unknown SPI chip (REMS), 0 kB: probe_spi_rems: id1 0x0, id2 0x0
Found Generic flash chip "unknown SPI chip (RDID)" (0 kB, SPI).
This flash part has status NOT WORKING for operations: PROBE READ ERASE WRITE
The test status of this chip may have been updated in the latest development
version of flashrom. If you are running the latest development version,
please email a report to flashrom@flashrom.org if any of the above operations
work correctly for you with this flash chip. Please include the flashrom log
file for all operations you tested (see the man page for details), and mention
which mainboard or programmer you tested in the subject line.
Thanks for your help!
Raw bitbang mode version 1
Bus Pirate shutdown completed.

Did you faced an issue like that ? Some mails sent to the flashrom mailing report list seem to be the same reports as i have but there aren't any successful replies...

I'm definitely reaching for help today :'(

Hope i will find a way to do it finally, best regards. :(