PDA

View Full Version : G74 green screen - need opinions



matador
12-20-2011, 08:18 PM
Comrades, I get green screen from my g74 during the boot up, when it goes into windows right after the sleep mode. It lasts only a sec, and doesn't create any problem.

Is this something I sshould be worried about, what do you think?

BTW, It's BBK8 model, and I still can return it.

fuzon1337
12-20-2011, 08:25 PM
I had the same issue, but I reinstalled the notebook (for other reasons then exact green screen) and installed the latest nVidia drivers and then I haven't seen it after the reinstallation.

I think it's caused by the graphic driver so if you uninstall the driver you got know and then (after a reboot) install it again to see if it's gone away? (if you not already have tried this)

xeromist
12-20-2011, 08:28 PM
Sounds like the display adapter isn't initializing properly on startup. Run some heavy benchmarks like Furmark and see if you get any freezes or artifacts. If you to then return it immediately. If you don't then it's up to you. It might be a sign of deeper problems or you may never see anything worse. If you haven't already invested deeply and made your nest then I'd just take to to BB, show them the issue, and get an exchange. Better to be safe than sorry.

BTW, latest driver? You might want to make sure you have it and see if it happens to go away.

matador
12-20-2011, 11:43 PM
Thanks for the replies, folks. I just updated 285.62 to 290.36 Beta, and the issue went away. Also, the Skyrim seems to run smoother.

Do you think it's enough or should I run other tests also?

xeromist
12-20-2011, 11:46 PM
Tests are easy so I'd say it's worth it, but given Fuzon's experience I'd say you probably don't have to.

Animoski12
12-21-2011, 12:03 AM
I have this issue as well.. Interesting enough, I have the same model and from Best Buy as well..

Let me know if you ever get the green screen again during boot up on the beta drivers, or any other issues for that matter. I'm running the latest non-beta drivers.

matador
12-21-2011, 03:26 AM
Tests are easy so I'd say it's worth it, but given Fuzon's experience I'd say you probably don't have to.

Thanks a lot.

matador
12-21-2011, 03:29 AM
I have this issue as well.. Interesting enough, I have the same model and from Best Buy as well..

Let me know if you ever get the green screen again during boot up on the beta drivers, or any other issues for that matter. I'm running the latest non-beta drivers.

In a couple of days I'll provide an update on this situation.

matador
12-23-2011, 11:35 PM
First of all Happy Holidays.

Now the promised update - 290.36 driver works and no green screen. Today installed the 290.53 thing, which is working so far.