PDA

View Full Version : G501JW BIOS Downgrade Problem to Install Samsung XP941 SSD



bertyjoe
10-22-2015, 12:06 AM
Greetings to you all! I’m new to this forum and will be grateful if someone could be of help to my problem.

I recently bought a fairly used ASUS ROG G501 model G501JW-CN168H with window 8.1 factory installed.

I then decided to upgrade it to Win 10 Education and also upgraded the hard drives to SSD, since I had 2 SSDs already, i.e. a 512gb Sandisk X300s and a 256gb Samsung XP941 both M.2. So I had 2 choices but decided to use the 512gb Sandisk since I wanted more space. It originally came with Sandisk 128gb SSD.

But before installing the 512gb Sandisk, I decided to test the Samsung XP941 for it functionality on the system. So I installed the Samsung XP941 first and could see it in the BIOS setup. I then removed it and installed the Sandisk SSD. I then preceded with a fresh installation of windows 10 on the 512gb Sandisk X300s. From the Asus website, I also downloaded and installed all available drivers and also did a BIOS update.

I later on sold the 256gb Samsung XP941 and bought a 512gb Samsung XP941, thinking the installation would be as smooth like before. But to my greatest surprise, this was not recognised in the BIOS settings. I also tried to do a BIOS downgrade using the Winflash method with “nodate” but it always booted back to windows without any downgrade attempt.

Unfortunately I did not do any backup of the original system file, so I really can’t get the system back to its original state. Please, can somebody help me to get the Samsung SSD install? Or how to get back to the previous BIOS version? I have also tried BIOS setting tricks by changing to CSM and other setting I found online but still without any success.

I’ll very much appreciate any help. Thanks

kaps26
10-26-2015, 02:58 PM
I advise you to remove from the laptop all the information storages except the 512gb Samsung XP941 and try to install a clean Windows 10.
The UEFI do not display connected information storages, but only the loader.

bertyjoe
10-26-2015, 11:27 PM
Hi, thanks for replying to my thread.
I tried that already but could not install still. I disconnected all other drives like the HDD and only had the XP941 ssd inside. From the bios setting, I could not see the any drive installed. However, I still when ahead and pluged in my usb win 10 installatin drive and booted up from usb for the installation. When I got to disk selection, no drive was found. I tried this many times without successs.

I don't know what I did wrong, in case you have any other idea, i will appreciate and try it out as well.

Thanks.