PDA

View Full Version : G750JZ Strange Power Problem (not working on battery)



taylajee
10-28-2015, 11:29 PM
Hi,
I searched the forums but I couldn't find my problem.
I have a G750JZ laptop, comes with a core i7 processor and a GTX 880M GPU. It is working flawlessly and is still in an excellent condition. However, as soon as I unplug the AC the laptop shuts down, or to be more precise, it powers off immediately.
The battery is fully charged (99% or 100%) but the laptop would not work on battery. It will not boot if I press the power button on battery, as if there is no battery at all.
Since my brother has the exact same laptop (G750JZ with the same exact specifications, we bought two units together) I tried to use his battery on my laptop, but it will not work. If I plug the AC, it will work again with nothing wrong at all.
Please, I'm lost with this problem although I have good experience in dealing computer systems.

taylajee
11-01-2015, 08:45 PM
UPDATE:
The battery now is on 93% and not charging, while the battery LED is blinking in orange!
So, is there anyone with any thought about this?

navis995
11-02-2015, 07:02 AM
That's normal. Instead of charging to full it stays at X usually above 90% and stays there. That's the way this new smart batteries work.

TL:DR It's normal and nothing to worry about.

code9523
11-03-2015, 02:09 PM
UPDATE:
The battery now is on 93% and not charging, while the battery LED is blinking in orange!
So, is there anyone with any thought about this?

Orange indicator should not blink! Even when it's on 93% it should shine green light! Blinking orange indicator is a hardware problem! It's shows that there is a problem while charging even empty battery it should shine not blink! I had same issue on asus g750js.

taylajee
11-04-2015, 04:42 AM
I'm sure it is a hardware problem. What I needed to know is what exactly the problem is? Is it a power circuit problem? Is the power circuit part of the motherboard (so I need to fix the MB)?
I wanted to see if anyone else had this happened to him and what was the problem? Or if an ASUS respondent can explain to me.

code9523
11-04-2015, 08:18 AM
This is more related to motherboard because I tried 2 batteries and 2 powerbrics on my and the problem didn't gone. Also I sold it with that problem so I don't know solution for it. But from most my knowledge it's related to motherboard power controller.