View Full Version : G751JY FPS problems with various games

11-03-2015, 03:19 PM
I have strange fps drops(slight freezes) with different games.
These are my laptop specs:

Proseccor: i7-4720HQ
GPU: Geforce GTX 980M, driver version 353.62
Memory 8+8 Gigs (8 originally, another 8 gigs added in store)
Hard drive: 1 tb Hdd + 256 ssd

I have fps problems with some of my games and some have no problems.

I have tested with following games ( games and whether they are installed to the hdd or sdd).

Skyrim (no problems, ssd. Had random fps drops when in hdd)
Star wars old republic (no problems, hdd )
Kingdom (no problems, hdd)
The war of mine (no problems, hdd)
Starcraft 2 (no problems, ssd)
Galactic civilizations 3 (no problems, hdd)

Sunless sea (problems, hdd)
Pillars of eternity (problems, tested both sdd and hdd)
Starpoint gemini 2 (problems, hdd)
Divinity dragon commander (problems, but only randomly, hdd)
Shadowrun Hong Kong (problems, ssd)

To check if the problem is with the hard drive, i ran two diagnostic programs to check their health.
(CrystalDiskInfo for both SDD and HDD and manufacturer´s tool (WinDFT) for HDD). Both gave good results and no problems.

To check if the problem is with RAM i ran windows memory diagnostic tool with standard settings. Results show no problems.

What you guys think? What could be the problem? Or is it just driver problem? Thanks in advance!

11-06-2015, 02:29 AM
I would check your temps. Heat might be throttling your system. Do a search on this forum and you will find that this is quite a common problem. A quick look at your games shows that the older ones are running with no problems ( starcraft etc) That might be your first clue. Older games are less demanding and they don't push your temps as high. Good luck!

11-06-2015, 02:45 AM
If the problems always occur only in certain games then the software or drivers could be at fault. The sorts of things NVidia patches up after too many people complain, lol.

11-06-2015, 06:19 AM
I checked temps when playing using hwinfo64.
After playing starpoint gemini 2 with max settings for one hour max temps were 70 degrees for cpu. No throttling
After playing starcraft 2 with max settings for two hours max temps were 80 degrees for cpu. No throttling

Also problems usually occur almost immediately after I start playing. Also changing graphic settings between lowest and
highest settings does not change things.

Some older games also have fps problems, like majesty 2.

Just praying it is software problem and not hardware problem.