PDA

View Full Version : ASUS ROG GX950 mouse - This is no joke - Prevents PC from booting



Severan
11-05-2015, 02:48 PM
This is a doozie, and I haven't been able to understand the issue at all.
First, I have two pcs, one, at my build sig, to the left. The other, has an asus H87M plus motherboard.
If I plug the mouse to my PC, 0 issues.
If I plug the mouse to the other pc (H87M) it will NOT boot. It will sit at a black screen. Nothing. No Bios, no post, no boot, no press anything.
I have updated the bios, no difference. I have switched PSUs, scoured the BIOs to turn off/on anything regarding USB devices, no difference.
If I unplug any and all USB devices, both outside, as well as inside the case, everything works. All my other mice work correctly.
If I plug that GX950 mouse to the H87m mobo, IT WILL NOT BOOT. I have confirmed that the mouse if running the correct and latest firmware.
I'm stumped. Any ideas?
Also, anyone knows the correct method to do a bios flashback on a H87M mobo to try and reflash the bios? I don't have a reset button on that case, and was wondering how to overcome that issue.

So, help? <3 Cheers!

InfernoStorm
11-09-2015, 03:55 AM
This type of issue happen lots to old HP and Dell desktop systems that I had a long time ago (most were previous systems that my clients own and they gave to me after I built them better systems). It's an issue where the motherboard is recognizing the mouse as a storage device which is disrupting the pre-post sequence so it's preventing the system from posting. Have you tried both the front and back USB ports? Have you tried this through an external hub?

Well the obvious simple solution is to not leave your mouse unplugged in when your system boots and then plug in it later after your system gets into Windows. Of course I'm sure that's not what you want to do, but if it's an issue with the motherboard then there's nothing much you can do.

Severan
11-09-2015, 04:39 PM
Thanks for the reply ^^
I have tried in both usb 3 and 2 ports, front and back, though it doesn't help that I scavenged the old chassis of an HP M9000 to make use of all the extras it had.
Guess I'll just leave the mouse unplugged until I finally bring myself to reflash another bios since there's a version out there boasting better usb compatibility... Though last time it gave me an error about validation. FML x.x;

InfernoStorm
11-10-2015, 01:35 AM
Yeah definitely try the new BIOS and see if it fixes the issue. Good luck to you mate.

NeoBeum
08-08-2016, 08:38 PM
Is this Windows 10?

Severan
01-25-2017, 09:34 PM
Forgot to update this thread, so sorry.
So it turns out the issue was the firmware of the ASUS motherboard itself.
Plug any old mouse, works. Plug the one mentioned, black screen.
Flashed an older BIOS, pc boots again. This, together with the issues I'm having with my spatha are seriously making me doubt ASUS.
It will take a really amazing support to get me to grab anything ASUS again :( Shame. I like the design and Stryx motto.