PDA

View Full Version : External hard drive disconnects and reconnects on G550JX



jshthng
11-09-2015, 05:28 PM
Hi I just got a new rog laptop, more specifically G550JX. When I plugged in my external hard drive, it was functioning well for a few hours. But after that few hours, the external hard drive just got disconnected and reconnected when I was watching a video from that external hard drive. The disconnect chime played and windows media player closed. After 1 Sec, the drive reconnected and windows explorer opened due to autoplay. I didn't touch the drive at all, just the mouse. This never happened when I connected the external hard drive to my old laptop which ran on Windows 7. This is also my first time using window 8.1 on G550JX. So my question is: is this disconnecting and reconnecting a problem with windows 8.1?

I just don't want this to happen too often as it will corrupt the external hard drive. Thanks for any advice!

InfernoStorm
11-10-2015, 06:24 AM
Welcome to the forum!

I assume of course that the external hard drive is connected to a USB 3.0 port? You might want to make sure that you have installed the latest USB 3.0 host controller drivers from the ASUS product page. The default Windows WDM drivers will work but there could be problems such as the one you mentioned so try installing the newest drivers and test again.

daviangel
11-10-2015, 11:33 AM
Hi I just got a new rog laptop, more specifically G550JX. When I plugged in my external hard drive, it was functioning well for a few hours. But after that few hours, the external hard drive just got disconnected and reconnected when I was watching a video from that external hard drive. The disconnect chime played and windows media player closed. After 1 Sec, the drive reconnected and windows explorer opened due to autoplay. I didn't touch the drive at all, just the mouse. This never happened when I connected the external hard drive to my old laptop which ran on Windows 7. This is also my first time using window 8.1 on G550JX. So my question is: is this disconnecting and reconnecting a problem with windows 8.1?

I just don't want this to happen too often as it will corrupt the external hard drive. Thanks for any advice!
No not Win 8.1 thing.
Will usually get this with:
bad cable
wrong/outdated usb drivers
sleep settings