PDA

View Full Version : G551JW - Windows 10 dpi issues with Steam and other Apps



KirIvlev
11-14-2015, 11:48 AM
Hey guys,

Just got a new brand G551JW. Immediately changed the stock 2TB HDD to a SSD drive and installed fresh Windows 10 on it.
It runs games very fast(latest nvidia driver installed).
Nevertheless I've got a very annoying problem. Since it's got a 15.6 inch screen and fullhd resolution the default window dpi setting is set to 125%(recommended by windows itself) to make things a little bit bigger. But unfortunately some apps like Steam and many others have very blurry text due to the dpi settings. If I set it to 100% everything is ok but very tiny and hard to read unless you put your face a few centimeters away from the screen :).

Am I the only one who's experiencing this problem? Is there any remedy to it?

Thanks in advance

dunedune
11-16-2015, 09:48 AM
Just remove Windows 10 ! This OS made for Dump idiots who didnt experienced windows 7 .... Many users reported tons of problems in windows 10 .
So i suggest to downgrade to windows 8.1 ,There's no differences between them ... Windows 10 even more ugly and worthless

toronto699
11-16-2015, 02:46 PM
try this
ctrl + larger text
ctrl - smaller text

Corporal
11-16-2015, 02:57 PM
Just remove Windows 10 ! This OS made for Dump idiots who didnt experienced windows 7 .... Many users reported tons of problems in windows 10 .
So i suggest to downgrade to windows 8.1 ,There's no differences between them ... Windows 10 even more ugly and worthless
His problem has nothing to do with windows 10. DPI bugs have been there since windows vista, because app developers haven't implemented DPI scaling properly.
Set your DPI to whatever you like, then go to Steam shortcut, properties, compatibility, and check the "Disable display scaling on high DPI settings". Steam will then run in 100% DPI mode, while other programs will run in whatever DPI you like.

toronto699
11-16-2015, 03:13 PM
corporal thanks that was easy worked great