PDA

View Full Version : G751 Power cycling briefly from AC to Battery back to AC



wiwahib
11-14-2015, 06:39 PM
I sent my g751 in for an RMA for this problem and just got it back. They replaced the battery according to the repair sheet but it didn't fix the problem. I took a video of what is going on, but I don't know how to share on a forum. I grabbed some screenshots from the video and will post here. Has anyone experienced a problem with their laptop cycling briefly cycling from AC to DC back to AC? There doesn't seem to be any specific cause. It does it when I switch applications, but it also does it when it is just sitting there.

aeolisio
11-15-2015, 02:00 AM
I sent my g751 in for an RMA for this problem and just got it back. They replaced the battery according to the repair sheet but it didn't fix the problem. I took a video of what is going on, but I don't know how to share on a forum. I grabbed some screenshots from the video and will post here. Has anyone experienced a problem with their laptop cycling briefly cycling from AC to DC back to AC? There doesn't seem to be any specific cause. It does it when I switch applications, but it also does it when it is just sitting there.
It cycling would not have anything to do with the battery. Its either the your outlet not providing enough power or clean enough power or your power supply, the dc jack or the board but usually its the power supply. Have you tried jiggling the jack and other outlets in other locations? I would rma it again with as much proof as you can provide

wiwahib
11-16-2015, 07:02 PM
It cycling would not have anything to do with the battery. Its either the your outlet not providing enough power or clean enough power or your power supply, the dc jack or the board but usually its the power supply. Have you tried jiggling the jack and other outlets in other locations? I would rma it again with as much proof as you can provide

I thought that was the case as well and tried different outlets. Jiggling the jack does not recreate the problem. I took some videos and sent it into for repair today. Thank you for your insight!

GrizzlyLewy
11-16-2015, 07:46 PM
I had a same problem with mine the it stopped literally charging it so I sended to service but still waiting for information...