View Full Version : Anyone successfully installed Intel Rapid Storage Technology on G74SX in Windows 10?

12-02-2015, 10:10 PM
Anyone successfully installed and use Intel Rapid Storage Technology on the G74SX in Windows 10 v1511 Build 10586? I installed and was using Intel Rapid Storage Technology Version WHQL in WIndows 10 RTM Build 10240 but after upgrading to Windows 10 v1511 Build 10586, it appears that while Intel RST still shows up in Programs and Features, neither the files or folders still exist. Reinstalling only says it installed successfully but it never installed any files. Anyone here using Intel RST on the G74SX in 10586 or later?

01-06-2016, 06:13 PM
I would really like to know the same! Seems like new IRST drivers (from v13) don't support Asus G74SX chipset anymore (Intel 6-Series Chipsets).
What AHCI drivers are the best currently for Asus G74SX that support Windows 10? Has anyone tested that?

01-08-2016, 06:09 AM
There aren't any since the Intel Chipset INF will support everything else and while the newest version may not support the G74SX using the latest drivers, it will install the latest version available for the G74SX. RST 12 is the last one that supports the G74SX's chipset so unless there is a newer RST 12, it will not work. RST 12 did work with Windows 10 Build 10240 RTM but not Build 10586 or later. RST is also a discontinued product as it's supposedly for RAID which Windows 10 is supposed to already support natively.

01-09-2016, 04:04 PM
Hi guys, I used christmass free time to upgrade my G74SX to Win10 (last version). Everything works fine except one thing. Althought with latest ATK Package installed, I have little problems with display backlight control. I can visualy see all the 11 levels of backlight power (including minimal and maximal) like in Win7, but some of them dont work! When pressing e.g. Fn+F6 from minimal state, only 3rd state change backlight physicaly then 4th works...etc. So from the whole range there is only 7 states are physicaly working. Anyone solved this problem?

From other things Power4gear was replaced by Power4gear hybrid and I solved dimming keyboard backlight with regedit...

If you experience drivers problems try this site:http://ivanrf.com/en/latest-asus-drivers-for-windows-10/

01-10-2016, 08:00 PM
Not sure about the backlight as I have never checked how many levels of backlight there is now but I'll check now. You are right, there are 11 levels but some of them don't seem to have any effect when selected. Power4Gear was akways called Power4Gear Hybrid even though the former was a older version. What exactly did you do in regedit? Also, I still have Wireless Console 3 installed even though I changed to a Intel 7260AC WiFi/Bluetooth Card but the issue is my wifi light is not on and I basically have to fn-f2 to toggle off and then on again before the light is on.