View Full Version : G75vw shutdown and no usb 3.0

12-26-2015, 02:25 PM
What I did:
-A clean install of Windows 10,
-Installed the Nvidia drivers, and the light keyboard,
-Didn't install bluetooth, wifi, ethernet since it was already working.

Issues I have:
-Installed Touchpad driver so it could be disabled when I connect a mouse, but the windows 7 version of the driver I found on Asus website didn't work with windows 10 apparently.

-Tested the speed of my Sandisk Extreme USB key 3.0 : 30mo/s... so it's usb 2.0, not usb 3.0
So I installed the Chipset driver for windows 8 : Chipset_Intel_Win8_64_Z9301021
And Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver
But still no usb 3.0

-Sometimes, even not in games, the pc shutdown,but it's not hot.

My questions:
-Is there a working touchpad driver ?
-Can I have usb 3.0 ?
-Do I need others drivers for gaming ?
-Why my pc shutdown ?

Thanks for reading this.

01-28-2016, 08:34 PM
I have the same problems, No USB 3.0 and random shut downs. No idea how to fix it.

02-01-2016, 12:37 AM
If you have any intel rapid storage software on your computer.. remove it. Also. Install the latest Intel chip set drivers which contain usb 3.0 drivers.


Windows 10 however updates these automatically. Hope this helps :)

02-01-2016, 06:28 AM
I've been very happy with upgrading from Windows 8.1 to W10. My previous install worked very well and W10 upgrade was fast and all hardware works very well. Most of my desktop applications we still working fine. I mainly needed to upgrade the Nvidia drivers and Norton Security and reload my Windows Store apps.

If you have the option, I recommend the upgrade route vs clean install.