PDA

View Full Version : Luxmark.exe crashing



OCD guy
12-28-2015, 11:25 PM
Ok so when I run the stress test in RealBench I keep getting a black screen, the driver stopped responding message and Luxmark.exe stopped working.

My initial thought was instability, however with my whole system at stock I'd still get the same thing happening.

Anyway after much experimentation it turns out when I don't run certain monitoring software I don't get the crash.

Monitoring software such aida64 causes the crash. When I close aida64 and then run the stress test, RealBench shows "Result Hash Match!"

So my question to you is, is my system unstable? Or can I just simply assume for whatever reason that certain monitoring software causes a conflict?

Surely if my system was really unstable I'd get the crash regardless? But the other side of me thinks that I should be able to have monitoring software work in the background .

I'd be curious to know if this is a known bug, perhaps monitoring software polling gpu readings causes a crash in luxmark, but in saying that EVGA precision X runs fine in the background.

OCD guy
12-31-2015, 06:00 AM
Ok after much testing I can confirm that whenever I run RealBench with any graphic card monitoring software, whether it be msi afterburner, precision X etc luxmark will crash without fail.

When theses applications are not running I pass the stability tests.

Is this a bug? Conflict?

river.dog
02-22-2016, 05:26 PM
Ok after much testing I can confirm that whenever I run RealBench with any graphic card monitoring software, whether it be msi afterburner, precision X etc luxmark will crash without fail.

When theses applications are not running I pass the stability tests.

Is this a bug? Conflict?

I've noticed this kind of issue in the past while in game as well. When OSD is on for EVGA Precision, some games crash or don't run well. I believe it's been that way since the beginning and there was some kind of message about how the OSD hooks to the game process or something like that.

Anyways, I also observed the same issue with RealBench and found that if you just disable the OSD, you can still run the software and monitor desktop temperatures. I like to use Precision because of the custom fan curve. Without it the video card temps skyrocket, but with it on, OSD disabled, I have achieved a reliable way to stress my overclocks. :)

Arne Saknussemm
02-22-2016, 08:12 PM
I have run RealBench many many times with GPUs OCd with PrecisionX and never had a problem...the OSD I don't really use though...

Luxmark crashes I have had I have remedied with fresh GPU driver install...

Nodens
02-29-2016, 11:39 AM
Indeed don't enable the OSD. River.dog is correct, these OSDs are made by hooking certain API functions. A lot of software is incompatible with them.

awyniesome
04-11-2017, 07:51 AM
Indeed don't enable the OSD. River.dog is correct, these OSDs are made by hooking certain API functions. A lot of software is incompatible with them.

Im new to this. i have the same error. My questions is how dk we disable OSD? Where do we go?
I am having intel 7700k
Mobo: strix z270F
GeForce 1070
*
And I get this Luxmark instabilty whenever I run stress test and benchmark.

Any help would be appreciated.

Thanks*

SKR-974
04-12-2017, 02:28 PM
hi,
Yesterday I did a test of two hour, the test of stress is passed without error,
A few hours later I do a test of 30 minutes, the stress test is passed but in the end the graphics driver stopped "nvlddmkm",
The graphics card has changed P-States from p2 to p8, 11110.5MHz to 324 MHz
With software running in the background: MSI AF + RTSS, CPU-Z, GPU-Z x2, HWiNFO64

MB : Asus Maximus VIII Hero - Bios 3401
CPU : I7 6700K @ 4.6GHz - 1.408 V / core x46 - cache x44 / 80 max load
GPU : GTX 690 @ Clock : 1110.5MHz / Mem : 3600MHz - 1.1750V / 80 max load
RAM :16GB DDR4 - (4x4) 2400MHz G.Skill Ripjaws V - F4-2400C15Q-16GVR
PSU : Cooler Master V1000 - 1000W
Cooling : Corsair Hydro Series H100i

Zka17
04-12-2017, 08:51 PM
The "graphics driver stopped working" thing is typically an OC failure on graphics cards... it may be caused by the OC itself or the driver...
As Arne said, a lot of times completely remove the driver and fresh install a new one may help... if not, just reduce the OC on the 690...

SKR-974
04-13-2017, 02:46 PM
I have the same problem with my old GTX 275 100% stock,
I have no problem under benchmarks like Valley Benchmark or 3DMark with overclock,
And Boost is disable on my GTX 690

Zka17
04-13-2017, 03:53 PM
GTX 275 and GTX 690 in one system? Do they still make drivers for those? Which OS are you on?

SKR-974
04-13-2017, 05:12 PM
No I used the GTX 275 just for test,
My OS is a W10 pro, GTX 275 uses GeForce 342.01 Driver and GeForce 381.65 for GTX 690
I cleaned the drivers with DDU and Driver Fusion Premium before reinstalling
I did a test of one hour and no problem with CPU and GPU OC
I just change the cache ratio, x44 to x41
Https://www.dropbox.com/s/lfyko5a62rw63cr/Screenshot1HRB.jpg

Zka17
04-13-2017, 08:05 PM
Yeap, it was too high CPU/cache clocks... I needed to reduce mine too...

SKR-974
04-14-2017, 02:12 PM
The problem is still here, after a stress test of 2 hours, I have a black screen, an nvlddmkm event, and the frequency of the gpu goes down to 324MHz.
I draw a line where the black screen appears, the message "Stress Test Passed!" is displayed and then black screen.

https://www.dropbox.com/s/dsaqgjb1qd6ckrj/2hy.jpg

Arne Saknussemm
04-14-2017, 05:04 PM
First thing to do would be reset CPU and GPU to stock and see if it still happens...

Zka17
04-14-2017, 10:47 PM
LOL, it just happened to me too! :o
I know that I had that Geforce Gaming experience thing on and automatically updated my driver... it seemed OK, but it is not...
Will re-install the driver, let's see what happens - will report back!

SKR-974
04-15-2017, 06:03 AM
CPU and GPU stock, same problem, nvlddmkm event, LuxMark.exe crash....
The problem appears after only 30 min.
https://www.dropbox.com/s/k1n8xv6k7vb2qrf/stock.jpg

SKR-974
04-15-2017, 11:28 AM
I did the stress test with CPU and GPU OC for 4 hours, the event nvlddmkm appears when the test ends, LuxMark does not crash.
The problem must come from the application and not from anything else.
Because if there was really a worry he would have planted during the test.
Maybe it is not compatible with the bi-GPU system or it does not support the GPU boost.

https://www.dropbox.com/s/eojui7qikgphtw7/RB4H.jpg

Zka17
04-16-2017, 12:48 PM
This is an issue! Did re-install the driver, even reduced the OC on CPU (previously stable, GPUs at stock) and have the same issue...
I observed that Win auto-installed new things, maybe something there is messing up the system...
Have to keep digging...

SKR-974
04-16-2017, 07:18 PM
I upgraded Windows 10 to "Windows 10 Creators Update",
I reset the system, reinstalled the drivers,
The problem is the same, black screen and nvlddmkm event at the end of the stress test,
I think I tried everything
Zka17 you can give me your config and settings please ?

Zka17
04-16-2017, 10:00 PM
Here it is:
Board: R5E10, cooling through a monoblock
CPU: 6900k, cooling through the monoblock
RAM: 64GB, 3200MHz
GPUs: Nvidia GeForce GTX 1080 Ti (2x), original cooling
SSD: 960 Pro
PSU: Seasonic, 1250W

I run the RAMs at their XMP settings, but manually entered the values
I had a stable OC on CPU at 4.4GHz, cache 3.4 - was passing every test, including the RB; then reduced to 4.0 GHz, cache 3.1GHz (RAM remained)...
I did memtest86+ and HCI memtest 500% in both settings with 0 errors... Also the GPUs are stock...

My OS is WIn 10 Pro. Fairly new... killed Cortana and uninstalled Intern Turbo Boost 3.0 (this showed up after and auto update). Don't know yet how to stop the auto-updates.
Initially I had 378.92 driver with GeForce Experience (no problem observed that time), then the thing auto-updated to the 381.65 - when I observed trouble... I used the driver removal tool (DDU, I guess is called) in safe mode, then clean installed the 381.65 only (no GeForce experience)... problem is still there...

3DMark Fire Strike works as a charm, can kill it only if I push the GPUs too high.
RealBench 2.54 testing runs as previously - does not show any problems in 2 consecutive runs.

I get the problem (Luxmark thing) when stress-testing with RB around 10-15 minutes... temps are fine (mid 50s at 4.0GHz)...

Oh, and I have GPU Tweak II and AIDA64 running in the background - did not try to kill them yet...

Let me know if I forgot something...

Zka17
04-17-2017, 06:49 PM
Here goes an update...

I have been redoing my OC in BIOS starting from default settings... well, spent a lot of time at default settings...
Luxmark.exe was crashing with the nvlddmkm event all the time...
Just could not commprehend - RB benchmark is passing, 3DMark FireStrike is passing at every level, even the new Superposition has passed with no issues... then RB stresstest is crashing again...
Start thinking that this can not be a hardware error... something is messing up RB - so started to kill applications running in the background...

And I have found something: STUPID GPU TWEAK II!!! Two Asus (related) softwares don't play nice with each other on an Asus board...

Well, before I noticed the RB stress-crashing problem, I have set GPU Tweak II to start with the OS, minimized to be available if needed... I've had a custom fan curve setup, more aggressive than its default - and it was doing it job as shown with other benchmarks...

If I set GPU Tweak II to open only when I click on it, set the max fan speed (tried only this), then close it - the fans will keep the setting, and RB stresstest will go on for at least one hour (the max I had time to try) without problems! :cool:

Edit: I never used OSD on this system...

SKR-974
04-18-2017, 09:14 AM
You have a very good config,
I'm never tried stress test without MSI Afterburner, I also use it for the speed of the fan,
And for overclock I use a script that works with Nvidia Inspector,
As soon as I can I would do a test without msi and I would post the result.

Zka17
04-18-2017, 02:57 PM
Use the MSI Afterburner to speed up the fans (I am doing 100% fan speed when benchmarking), then close it - make sure that it is not in the System Tray...

SKR-974
04-18-2017, 05:27 PM
I removed "MSI Afterburner" from auto startup,
I set the fan speed to max with nvidia inspector,
I did a stress test of 2 hours, no problem appeared from the beginning to the end,
Thank you for the information,
Now we need another software for the adjustment of the fan...

https://www.dropbox.com/s/ivi2ntxa9pq080r/2HRB.jpg

Zka17
04-18-2017, 08:55 PM
Nah, you can still use the MSI Afterburner if you like it - do your setting, hit apply, then quit... it will hold the settings...
Again, just make sure that you un-check the thing in its preferences about keeping it in the System Tray, and for that matter, also un-check the start with OS thing...
That way it's there when you need it, but won't interfere with RB...

SKR-974
04-19-2017, 03:30 PM
I tried but whenever I leave "MSI", the fan speed decreases

Zka17
04-20-2017, 07:03 AM
Oh, I see... then maybe try GPU Tweak...

Nodens
09-22-2017, 02:22 AM
Zka17 can you try and test if this also happens with GPU Tweak monitoring disabled?

Zka17
09-23-2017, 02:44 PM
That will take a while... I took apart my TestBench and my new system isn't ready yet. Will do as soon as possible!

Nodens
09-27-2017, 10:31 PM
Roger that :)

meankeys
09-30-2017, 02:50 PM
APEX VI - 7920X - 16 gb G.skill Trident Z - running @ 4612 mhz - SS cooling

Will run RB Perfectly with out the openCL driver installed - If I install driver 16.1.1 luxmark will crash everytime. I am using afterburner. Nodens suggested using an older driver. there was no change same results. Today I will uninstall afterburner and try again to test the theory of OSD etc. i will report back later

meankeys
09-30-2017, 06:03 PM
I ran RB no OpenCL driver installed - RB ran and preformed perfectly - - uninstalled afterburner - Installed OpenCL driver 15.1.1 also tried 16.1.1 same result - Luxmark crash.

tommiboi
10-18-2017, 08:40 AM
I have the same thing. Luxmark crashes all the time. Not able to use Realbench now. I tried everything.

meankeys
10-19-2017, 12:27 AM
I have the same thing. Luxmark crashes all the time. Not able to use Realbench now. I tried everything.

What CPU are you using?

Blake86
01-09-2018, 09:17 AM
me too, trident z 3200. stable with prime95 blend and small, passed windows memory diagnostic, no problem in game with 3 game opened at a time (almost all ram used) but no matter what, luxmark alwais crash after 4 or 5 seconds

Arne Saknussemm
01-12-2018, 06:33 PM
New driver make any difference 16.1.2 ?
https://software.intel.com/en-us/articles/opencl-drivers

tunc8686
01-12-2018, 09:54 PM
https://rog.asus.com/forum/showthread.php?98769-Realbench-2-56V-Image-Editing-Low-Score
Pls someone hep me ? *