PDA

View Full Version : G73jh HDMI output no longer working



guiguiny
12-30-2015, 11:08 AM
Hello,

I am the proud owner of a G73Jh with a Radeon 5870.
No longer a gamer the PC is hooked via hdmi to my A/V and is mainly used as a HTCP. I am sending to my A/V through VLC all my movies in glorious DTS and Dolby.
I am facing last week an issue where I can no longer output image nor sound through hdmi. I can see the screen switching off and back on and I can hear the windows sound indicating the receiver is now hooked. But still no image nor sound whether I duplicate or extend my desktop. I of course choose AMD Audio as an output and I can see the green levels moving (hence the output is recognizing a signal)..but no sound.
Window is recognizing my A/V, my projector or TV. HDMI seems then to perform a correct handshake….but still no sound nor image apart from my computer’s screen.

I have performed a clean uninstall/ install of AMD drivers
I have formatted windows
I even used a brand new SSD and moved to Win 10.

Still the same issue.

My guess is the Radeon is dead. But everything seems fine (no flickering on the PC’s screen). The devices are recognized…
What maked me dout is when the PC is hooked to my TV and booting, I can see the windows logo on the TV (So without evn the Radeon working) but the screen is very snowy. Could it be just the HDMI output and not the card?

Any hints would be greatly appreciated.

Cheers!!



Edit / Delete Edit Post Reply With Quote Reply With Quote Multi-Quote This Message

C4RN1
12-30-2015, 01:18 PM
Have you tried a different hdmi cable? Have you inspected the hdmi port for damage? Have you tested the hdmi port on the tv?

HDMI is tricky since it uses HDCP, the computer sends a signal to the tv, the tv responds and authorizes HDCP to broadcast. If you have a bad cable you could have a similar issue where one minute it works, the other it doesn't.

Check your connections...