View Full Version : G771 Clone OS and Recovery partition to M.2 PCIx SSD

01-05-2016, 04:38 PM
I am wondering if anybody has managed to successfully clone and make active (boot) the OS and recovery partition to an m.2 SSD (and if so, could perhaps offer some helpful advice.)

I have Asus G771J(w?) shipped with 128Gb Kingston Sata SSD, 1Tb HDD and 8Gb DDR - I have installed a 256Gb Samsung M.2 PCI SSD in the vacant slot. (Samsung sm951 ACHI - http://www.scan.co.uk/products/256gb-samsung-sm951-m2-(22x80)-pcie-30-(x4)-ahci-ssd-mlc-nand-read-2150mb-s-write-1200mb-s-90k-70k-i)

So far I have been able to clone the original OS drive and recovery paritions using Macruim Reflect (free) - these partitions are all visible if checked with partition / disk management software and only the OS partition is visible to the OS if booted with the original OS drive installed.
However, even if the new m.2 SSD is the only drive installed it will not boot succesfully, and indeed if I try to boot into recovery to recovery/reinstal from recovery partition this throws up numerous errors.

All advice appreciated. :-)

01-07-2016, 06:01 AM
Have you tried using the Samsung data migration tool to clone?


01-07-2016, 04:01 PM
When you clone you need to clone the entire disk there are hidden partitions that need to be cloned for the new SSD to boot. You can't just clone the C partition and recovery partition Video show you how (https://www.youtube.com/watch?v=q9nc1PAhieQ) Insure you boot your USB MR boot UEFI

01-08-2016, 04:50 AM
Yes, I actually tried that already. The Samsung data migration software (clonix) will detect my SSD (Sata) but will not see the sm951 m.2 PCIe which is the one I would ideally like to set up as the new OS & Recovery partition drive.

I even tried following your link to check I had the latest version of the Samsung tool and tried it once again. Same result.

The drive is detected by bios and OS. If I chose I could probably partition and format and use it as a data drive. (I can see the OS partition from the failed Macrium reflect clone attempt in windows/this pc/file explorer as I type this. (and can see all hidden partitions if I examine it with Macrium Reflect or Paragon Partition Manager. (free)

Original OS SSD is Kingston 128Gb Sata
New PCIe m.2 SSD is 256Gb Samsung sm951 AHCI PCIe (OS and ideally recovery partition to be cloned to this drive.)
New Data SSD Samsung Evo 850 500Gb

01-14-2016, 09:50 PM
Quick update

Macrium (free) has so far utterly refused to return usable results. I tried with Clonezilla and this worked straight away! - with some issue's.

Method I am using.
1. Clone Drive to drive. Whole drive, all partitions - not to image.
2. Turn off Laptop, remove power cord & battery, remove Original SSD (Kingston 128Gb)
3. Replace battery and power and attempt boot with only the cloned drive present.

This would NOT work with Macrium, not matter what I tried, no matter what settings in UEFI/BIOS I had - with the original drive replaced and the laptop booted with default EUFI/BIOS settings the laptop will boot to OS on Kingston and the OS partition on the cloned m.2 drive is visible to windows. The other partitions are not visible unless using partition management or clone software to interrogate.

This process DID work with Clonezilla and allowed a boot to OS with the clone drive as the only one present. However, attempting to "test" the process and the recovery partition results in the cloned drive becomming unbootable. Recovery partition or some interaction between EUFI/OEM OS Licence/cloned recovery partition results in permanent "Attempting to repair, unable to repair" loop.

Second attempt with clonezilla - same settings and process as before resulted in no boot.

I have also attempted to create an Asus recovery backup from the original using the Asus app. (create backup of recovery partition to USB and recovery from that.) This has not worked either.

Trying to verify the contents of the m.2 SSD by reinstalling the original Kingston SSD resulted in an automated disk repair which "refreshed" my original OS drive and somehow in the process my 500Gb data SSD (empty more or less) was turned from a single partition into 2 smaller partitions.

confused and a little frustrated. I may be forced to do a clean install to the m.2 SSD and just put the older drive into safe storage.

01-14-2016, 11:04 PM
One more thing comes to mind. First get back to where you started and clean the new drive where it ends up just like it was out of the box. Then initialize the drive before running the Samsung data migration tool. You don't have to have it partitioned but it does have to be initialized. If the drive is showing up then you should be able to clone and boot from it. The Samsung tool is the best free I've used. Acronis works very well for this, back ups and recovery. Best back up software I've ever used to date and I've been at this since before hard drives even existed. Acronis however is not free.
My first machine that actually had a hard drive (still no windows OS yet) was a whopping 40 MB. When I upgraded the drive when they got bigger it was a 540 MB and back then the cost of drives were $1 per MB. The machine was running a 480dxII CPU running at an astronomical 30 MHz! It was a beast and best in it's class until the first pentium running at 100MHz made it obsolete LOL. Yes I'm an old fart, past the half century mark.

Jon G
01-15-2016, 03:18 AM
On my G751JY BIOS AS211 I tried cloning my 256GB Samsung XP941 PCIe Gen2 M.2 ( AHCI ) SSD to a new 512GB
Samsung SM951 PCIe Gen3 M.2 ( AHCI ) SSD via BPlus U3M2M PCIe M.2 to USB 3.0 Adapter/enclosure using
EaseUs Todo Backup Home 9.1 clone operation. All clone attempts failed.
Went into BIOS boot menu, set boot option #1 to UEFI USB Flash device, removed the 256GB Samsung XP941 SSD,
installed the 512GB SM951 SSD and did a clean USB Flash install of Windows 10 64-bit. All is perfect now.
Save yourself the headache of trying to clone, it doesn't seem to work on these PCIe M.2 SSD's like it does on SATA 3 SSD's & HDD'S. Just remember to use only a USB Flash version of Windows OS for the ( UEFI ) install to SM951 and
you'll be good to go!

02-04-2016, 11:57 AM
The Samsung migration tool will not even recognize the drive's existence. (even when other tools will.) I think the SSD migration tool is specifically for the standard SSD's and not the PCIe ones.

Clonezilla worked as far as cloning the OS partition. I tried it several times and all were mostly succesfull in that the PCIe SSD would then boot as OS drive as it should. However, the recovery parition, while present never worked when tested.

Acronis, I was tempted to buy it. However, I found some posts online that indicated Acronis too had failed to make the recovery partition work.

I have been basically had to do a fresh install of Windows 8.1 and will upgrade to 10 asap.

02-04-2016, 02:08 PM
After using macrium and with new ssd installed only, have you tried to delete boot option? maybe this boot option is trying to find the old hardware.