PDA

View Full Version : Clean install of windows 10, and now audio sounds really bad HELP!



bbbeenn32
01-06-2016, 11:13 PM
I did a clean install of windows 10 on my G750 JW and everything works nice, but the sound. My sound sounds more canny, then before upgrade. It appears that I have Realtek installed, however I notice I do not have maxxaudio (or something of the sort) like before. All I want is to have my laptop sound like it did before, which sounded a lot fuller. Windows pretty much did everything automatically to this point, and I have sound but it sucks. The version of Realtek I have now is in picture below if that helps at all.

Any help would be GREAT!

Thanks,

Ben

toronto699
01-06-2016, 11:23 PM
even though this driver is for a desktop , I use it on my laptop {G751-JY} works well for me it has Max Audio {Audio Wizard} W10 version
https://www.asus.com/Tower-PCs/G11CB/HelpDesk_Download/

bbbeenn32
01-06-2016, 11:49 PM
What is the proper way to install it, because I am getting errors when I click the audio wizard Version 1.0.0.95? Thanks,

toronto699
01-07-2016, 01:37 AM
hmm ok , Try installing the Audio Wizard as Administrator , Right Click on file , run as administrator
or try installing the W8.1 driver for your G750jw , it should work in W10
http://support.asus.com.cn/Download.aspx?SLanguage=en&m=G750JW&p=3&s=521
or one of the audio drivers from the other G750 laptops
http://support.asus.com.cn/download/ModelList.aspx?SLanguage=en&keyword=G750&type=1
error 1722 is an installer error , that driver worked on another G750 laptop.
here is a posts of what others did
https://rog.asus.com/forum/showthread.php?73951-FIX-Windows-10-and-Asus-G750JS-Realtek-MaxxAudio-How-to-Get-it!&highlight=G750jw+audio+driver