PDA

View Full Version : G751db73 weird fan grind sound and dead pixel



KalEl
01-19-2016, 09:08 AM
I'm having an issue with my G751. It does have a dead pixel which turns green on boot. Then it kind of fades a little and blends in a bit after a while to a point where I don't even notice it. It's not that huge of a deal for me, but I've tried some pixel programs, and was wondering if there is anything else I can try to get rid of it.

The more prominent issue is the fan grind noise. The right fan seems to do it just right before it comes to a full stop. I also hear it for a second when it decides to spin up again. It's almost as if the blades are hitting something...but I'm puzzled as to why the blades would hit something only when it just comes to a complete stop? The performance of the laptop seems great thus far, the 970m is a beast. The screen is wonderful despite the dead pixel. There is a lot of great things about this laptop. But I'm afraid that maybe the fan bearing is going out or something. The laptop stays very cool, GPU stays around 35c idle, and cpu is around 37-38c idle so credit the Asus engineering :cool:. Of course these are winter temps too. Also my space bar makes a weird sound ask if there is a sticky plastic bag under it.

Even with these issues I love this laptop. Asus really out did themselves in the design of this majestic beast! I'm hoping to fix some of these issues however. I've researched the threads and can't seem to find a similar issue to the fan problem, I only see the realtek audio issue, and this one doesn't have any audio issues. I can live with these issues however, so long as I know the fan isn't going to eventually die. I'm just wondering if I should take out the fans and lube them, or replace them.