PDA

View Full Version : G52VY Black Screen on Startup



SteaK n Cheese
01-21-2016, 02:02 PM
Hi everyone!

When I start up my G52VY sometimes even before the ROG screen I get a black screen with the backlight on.I tried to wait it out but it dididn`t seem to solve anything. However when that happens i just press the power button once and the laptop gets turned off. Then when I turn it on again it all works fine. It happens like every four/five times I turn on my laptop. Any idea what causes that?

Thank you in advance!

JustinThyme
01-21-2016, 03:42 PM
just to eliminate the display being off try pressing FN F7 next time and see what happens.

Bodhmall
01-21-2016, 03:51 PM
Hi everyone!

When I start up my G52VY sometimes even before the ROG screen I get a black screen with the backlight on.I tried to wait it out but it dididn`t seem to solve anything. However when that happens i just press the power button once and the laptop gets turned off. Then when I turn it on again it all works fine. It happens like every four/five times I turn on my laptop. Any idea what causes that?

Thank you in advance!

I used to get the same on my G751JY and tried all the suggested bios / windows settings about hibernation but what I found to work was I wasn't shutting it down correctly
when shutting down the screen would go blank and I would close the lid before it had finished (white disk activity led still flashing)
now I wait for all the led's to stop flashing then close the lid and haven't had the issue since

SteaK n Cheese
01-23-2016, 09:41 AM
just to eliminate the display being off try pressing FN F7 next time and see what happens.

I will try that the next time and tell you what happens!




I used to get the same on my G751JY and tried all the suggested bios / windows settings about hibernation but what I found to work was I wasn't shutting it down correctly
when shutting down the screen would go blank and I would close the lid before it had finished (white disk activity led still flashing)
now I wait for all the led's to stop flashing then close the lid and haven't had the issue since

I doubt that would be my problem since I chose it to do nothing when I close the lid but I will check it the next time and tell you too!

Thanks guys.

SteaK n Cheese
01-24-2016, 10:51 AM
Well nothing seemed to work guys. It was the same result. It just went back to normal when I hit the power button again and turned it on one more time.

Jlieu
01-24-2016, 12:32 PM
I suggest RMA It.

SteaK n Cheese
01-24-2016, 12:38 PM
I suggest RMA It.

Do you think this is such a big deal to RMA it? I am just asking, because I don`t know.

Mashiro Shiina
04-20-2016, 09:26 PM
I am having the same trouble. I have bought my laptop 1 week ago and I cannot even open it. I am going to send it to RMA next week. Can anyone advice me something :(

And there is something that I have noticed. When the computer is turned off, mouse light is on which means USB ports are working. But as soon as I press the power button, USB ports stops delivering power.