View Full Version : AC56R 1300 and AC55 1300 heeelp? G751JY with Windows 10

02-18-2016, 12:51 AM
I bought both of these USB wifi cards to utilize my RT-AC87R wifi speeds and neither of them worked.
Bought the AC55 first, max speeds came to about 220mbps (compared to the 420 i get on my onboard wifi chip). Tried many different drivers and installers, nothing fixed it so i returned it.
Then i picked up the AC56R since it was on sale, supposedly more powerful than the AC55. Max speed i get is around 350mbps. Not only that, but the device continuously BSOD and froze/crashed my system.

System info: G751JY, windows 10.
Also tried both of these devices on a surface pro 4, same exat problems happen.
RT-AC87R 5ghz channel, should outpout from 700-800mbps (fibre network)

Does anybody have experience with the AC56 that can help me before I return it?

02-18-2016, 03:01 AM
I don't quite understand. Is your onboard card not an Intel AC7260? That has the same connection speed as any USB adapter on the market ATM. They are topping out at 867Mbps connections. The only thing I know that is capable of any faster plugs into the pcie slot of a desktop motherboard. We all have the need for speed and it's getting to the point that even the RT87 is slow with AC 5400 out now that supersedes a wired connection. Problem is nothing can use it and it's only advantage at this point are features that manage the network and connected devices with the way bandwidth is handled with more and more wireless devices in the home these days.

I honestly don't think you will top the speed of your PCIe half card that is already installed. There a lots of tweaks for through put on the router and the card but nothing that will make any significant changes in throughout other than a good signal with minimal interference.

02-18-2016, 03:26 AM
Yup the onboard card is an intel AC7260, but i only reach speeds up to around 425 mbps max. I wasnt aware that card could reach speeds of 800. Most of my friends get stronger connections on their macs and newer generation of asus rog laptops.
Perhaps there is something wrong with my laptop then...