PDA

View Full Version : Audio question:



beyondsonic
12-25-2011, 10:13 AM
Hey everyone, new at the forum, I just bought a G73 for school and music production. Fantastic machine so far, except..
...the audio is awful. The laptop speakers are great, but when I plug in my studio headphones, I hear it: Asus has hidden some "audio enhancement" feature somewhere inaccessible. There seems to be a built-in compressor and EQ. Through the laptop speakers it's fine, maybe through earbuds it's OK, but when I'm trying to hear my music for what it is it is absolutely awful.

What I need to know is if there is any way to turn it off for good. It's not the "Enhancements" tab under speaker properties. I have control over that, but the hidden compression does not go away when they are all disabled. Every other sound setting on the computer I've dealt with. I know it's an inaccessible tweak somewhere or maybe a bit of bloatware I can't find.

I also know it's not the fault of my hearing or my headphones: I trust them both. Besides that, in my audio software, I can chose whether I'm using the computer's audio drivers for the speakers or the software's audio drivers for the speakers. With the computer's drivers, it sounds the same, but when I chose the software's drivers, the hidden compression and EQ go away and I hear my music as it naturally sounds.

All my drivers are up-to-date, and if someone here knows a particular driver does this automatically, I'd be nice to know where I could get an "unadulterated" driver.
It's like buying a Lexus, but the car decides you are cold and turns on your heated seat and never lets you turn it off. I need your help to find and turn off this infuriatingly unnecessary feature. Can anybody help me?

JRd1st
12-25-2011, 12:08 PM
See if you have THX running. Also the realtek audio manager has an equalizer. But I think it's THX you're hearing.