PDA

View Full Version : G751JY BIOS211 fails to resume from hibernation every other reboot (0xc0000411)



hexaae
02-26-2016, 01:37 AM
Exactly as reported here from another user: http://superuser.com/questions/484537/windows-fails-to-resume-from-hibernation-every-other-reboot
I have the same issue.

I have hibernation enabled (not hybrid standby!) from start menu.
I've noticed that G751JY fails to resume from hibernation exactly every other reboot, not randomly. I can reproduce the problem.

Repro steps:
1. Shutdown Windows completely (do not select shutdown and reboot, but full Shudown only)
2. Click power button and boot
3. Enter Windows. Now reboot from Windows (do not shutdown!)
4. Enter Windows. Now if you put system in hibernation and try to resume it will cold reboot and Windows Event Viewer will report a kernel-boot error ID 16: "Windows failed to resume from hibernate with error status 0xc0000411"
at this point, next time you enter Windows right after the anomaly and hibernate, it will work absolutely fine... till next reboot!!

Everything is absolutely fine in my system, all drivers updated, BIOS 211 (Default settings reloaded & saved), Windows 10 x64 10586.104, my gfx card is GTX 980M PCI\VEN_10DE&DEV_13D7&SUBSYS_22DA1043&REV_A1\4&266 0345B&0&0008, i7 4710HQ. Exact model: G751JY-T7134H. I have 2 SSD connected to SATA3 and SATA2 ports:
http://s24.postimg.org/uianzp3g1/Cattura.jpg (http://postimg.org/image/uianzp3g1/)
My system comes from stock Win 8.1 upgraded to Win 10 using Microsoft auto-update, and not from a clean Win 10 install.


It looks like an issue with UEFI BIOS left in a bad status after you reboot once. If you shutdown, or you come from a previous cold reboot error, hibernation will work fine, till your next reboot.

You can find a log history with unexpected shutdowns typing "reliability monitor" in Cortana...

P.S.
This bug won't be solved re-flashing BIOS

hexaae
02-26-2016, 03:21 AM
UPDATE:
From BIOS if I disable SecureBoot + enable 'Launch CSM', resume from hibernation will NEVER fail.
Tried also SecureBoot ON + no FastBoot but the issue was still reproducible.

Definitely a UEFI BIOS bug with Windows 10 AFAICS...

xdr
02-26-2016, 04:21 PM
https://rog.asus.com/forum/showthread.php?76956-G751JY-Sleep-problem-with-Windows-10

Reflash your BIOS.

diogogmaio
02-26-2016, 04:53 PM
Yep. just reflash.

diogogmaio
02-26-2016, 04:54 PM
cmd line .... nodate....search google

hexaae
02-27-2016, 12:08 PM
No won't be solved by a reflash (already knew that trick to solve standby issues, nothing to do with hibernation).
This one is a different issue and I already tried a BIOS reflash.

Please, can you try the above mentioned steps (on a G751JY with BIOS 211 and Windows 10 x64) carefully and let me know if you can reproduce the issue? Thank you

A few user use hibernation, and with a fast SSD many couldn't even notice when the system was shut-down incorrectly because of error 0xc0000411 in a resume attempt from hibernation (you'll just find it in Event Viewer, no BSOD or anything else, besides noticing the desktop gets fully reloaded...). It wouldn't be a surprise if just me and a few others have noticed the problem.

See pic to check if your system ever had that issue. Run Event Viewer and double-click on error ID 16 to see a detailed history, if you use hibernation often.
2nd pic: You can filter 'Windows Logs/System' by 'Event ID': 16 and 'Source': Kernel-Boot

hexaae
02-28-2016, 11:47 PM
Someone can test this please?

hexaae
03-03-2016, 01:33 AM
Am I the only one using Hibernation?

JustinThyme
03-03-2016, 03:39 AM
Am I the only one using Hibernation?

Don't know about the only one but certainly one of the few. I don't use it, sleep and hibernation are disabled. Back in the days of spinners and an OS that took forever to get to the point of being ready to use I did deploy hibernation often, particularly on the crappy work laptops that my company issues.

With a high performance machine and SSD's The difference between resuming from hibernation and a cold boot is negligible for me.

hexaae
03-03-2016, 11:29 AM
Yes, but you can leave all your work (program windows etc.) intact and continue from where you were. It freezes computer status and internal Windows caching system will work better with faster PC usage.

I'm afraid it's a serious BIOS issue anyway as it's reproducible like the old bug 'resume from standby problem' with previous ASUS BIOS. Unfortunately even re-flash in this case doesn't solve this problem.
ASUS should seriously fix it since at present (BIOS 211) hibernation is unreliable on G751JY if you reboot + hibernate + resume, and then reboot + hibernate + resume (fails with error 0xc0000411!) again...
Current only workaround I've found is disabling Secureboot (and Fastboot), and go back to CSM, sigh... In this case hibernation resume will never fail.

JustinThyme
03-03-2016, 01:50 PM
I never have and never will get up from any PC without having saved my work and when I'm done I exit all programs. Hibernate doesn't freeze anything. It dumps the kernel and, whats in memory and loaded drivers to a file, hiberfil.sys, on the HDD then reloads those upon resume. Biggest reason I dont use it other than the fact that Im not so pressed for time that I cant wait a few seconds is its unnecessary writes to the SSD drive, 5-10GB every time.

Please explain your theory behind "Internal windows caching system will work better with faster PC usage". I've been at this for better than 30 years and that's a new one on me. Sound like a paraphrase right out of the book "if you cant dazzle them with brilliance then baffle them with BS".

hexaae
03-03-2016, 11:46 PM
It's a technology and a fact, not theory: Superfetch and Prefetch
But I'd prefer to keep on focus about the Hibernation bug instead of starting another useless flame vs benefits or not of Superfetch.

hexaae
03-07-2016, 07:25 PM
Please, I need help from a volunteer to verify this G751JY BIOS 211 bug....

hexaae
03-16-2016, 12:18 AM
BIOS bug still reproducible.

Dclubfoto
03-16-2016, 02:34 AM
I experienced that problem before. I did re-install win8.1 on my G752VT and problem is the ""SerialIO_Intel_Win10_64_VER30100151907" You can try re-installing the driver

Ekk

hexaae
03-18-2016, 01:39 PM
I'm afraid there is no such driver for G751JY... but thanks

hexaae
05-13-2016, 06:51 PM
I finally put my hands back on my G751JY, and for whatever reason maybe after ASUS Holland G-Sync upgrade and some software updates, the issue seems gone hopefully.