View Full Version : CS GO FPS drops, i7 4710HQ clock drops to 0

02-28-2016, 04:20 PM
Hello !

I have my G751JY for quite a long time now, and I'm happy with it.
I always had micro stuttering in CS:GO, but I thought it was network related, until I tried to fix it.

First of all, my config :
i7 4710HQ
16gb DDR3
GTX 980m
Power mode : maximum performance
EDIT : BIOS 205, CPS temps always below 70C, no thermal throttling (according to HWinfo)

So, the issue is that after monitoring the computer, I noticed that from time to time, the CPU clock of the core 0 drops to 0. I have a graph showing it thanks to the monitoring :


EDIT : noticed something more :


I am not sure if this is related to the stuttering, but for instance in CSGO, I'm always around 200-300fps, but sometimes FPS drops to 2 or 3 (I see it thanks to cl_showfps2), so I guess it may by an explanation.

I've read that it may be a monitoring issue from HWinfo, but the topic related is from 2011, I guess it must be fixed...

Is someone aware of such a problem, and is there a way to fix it ?

Thanks :)

02-28-2016, 06:42 PM
drop down your multi to 33 or lower and look if the issue persistent. someone has posted already cs frame drops... or lock cs only to one core in taskmanager core 0.

02-28-2016, 08:28 PM
Actually the multiplier is, 95% of the time, both on CSGO and GTA5, under 33 in game.
The multipliers go to 35 when I launch the games and when I quit them, but in game the multiplier seem to stick to 33


The issue with the core 0 dropping to 0mhz is still present in GTAV, but I don't feel any fps drop (maybe because the game is less "fast paced")

And I actually did force CSGO to use only 1 core (core 0) and it was not playable at all (no more than 100fps, which is bad for CSGO)
Then, I tried the opposite... and it seems to be kinda working ! I started by removing core 0, then I removed core 1 too, and now the fps don't drop below 26-31, when they dropped to 2-3 before. I mean it still happens, but far less often.

02-28-2016, 09:55 PM
If you are patient enough, I will provide a tool about this know issue on Haswell CPU (also Skylake) due to wrong TDP usage.
Can you try something please ?
Launch the game in OGL and let me know if you face the same issue.
Thank you

02-29-2016, 07:22 AM
Haha I'm patient, I won't change this computer for a looooong time :D That would be nice btw :)

I'm not sure if it is possible to launch CSGO in OpenGL. I tried to put -gl in the launch options, but it didn't change anything. I'll try to search more about that

03-02-2016, 02:01 PM
Someone ? :P

03-02-2016, 05:28 PM
Sorry Kommandoh, couldn't answer before, can you try using the "-w 1366" to force Ogl on CS:GO.
Btw CS:GO have a full OGL support, reason why you can see this one running on SteamOS ;).
I ask you to try with OGL because there is some bug with DX (wrong CPU usage for audio part).
You could also try to force DX11 (-dx11) to see if it run better for you than DX9.
It can also be due to a wrong power consumption
But let's do something, first try what I say above.
Also launch CS:GO/GTA V, try something, open task manager, choose the process related to your game and set priority to high instead of normal (you can also try above normal) check if you still have the same problem.
For me it look like the core 0 fail into limit usage or probably that the Engine ask too much of it and do call another core, this often happen to old engine but try everything above and I will check how I can help you.

03-02-2016, 09:31 PM
I'll try all of that and keep you up to date, thank you very much :) I'll probably post on friday/saturday