PDA

View Full Version : HDD speed "in the left slot" lower than 10MB/S



MaxCioco
03-04-2016, 03:21 PM
So, I've been using a config of a ssd and a hdd since I bough the laptop, everything working out all right.
A couple of months back I decided to swap my dead optical unit for a caddy for a second HDD, identical to the first one.

Now came along the problem:

The hdd that is inside the laptop runs at a maximum speed of 10MB/S. So low, it usually takes ~5 mins to open it when I double click it. Not to mention that Steam sees the drive as "faulty" when I try to install Steam games on it.
Strange enought, the drive in caddy recives from the ssd files with a speed up to 140MB/S. I tried pulling out the caddy, but the speed is not changed.

Then I tried pulling out the usual hdd and leaving only the caddy. It worked prefect. Not I put back the inside hdd and still does not work.

Randomly, after a few days it started to work properly. And for a time I forgot about it.

Now, after ~500TBW I decided it was time to change the ssd, due to safety reasons - I don't want all my data gone, and I found a nice offer for a 240GB Samsung 850EVO (50$ new on a store that was closing and liquidating all stocks).
So, ofc I took the offer and I decided not to clone ssd, just go for a clean install.

But here is the thing: when I reinstalled I took out the caddy hdd cuz I need a portable hdd and left the slot open. I formated the hdd inside too(with DBAN). So 2 clean drives. Now, the HDD has once again miserable speeds.

What can I do?
Did anyone encounter anything like it?
Is there anything I can do?

Note: old ssd: 850 Evo , new sdd: 850 EVO (first one was bough by me too, didn't came with the laptop)
hdds: HGST 1TB 7200RPM (one of them was in the laptop when I bough it)
caddy: Orico LX Series L127SS

Other mentions:

When I open my laptop the usage on the hdd is 100% for a few mins, while the ssd behaves normally. Only after that 100% usage stops I can use it.
I tried to disable the odd from bios. Did nothing it all.

Strange enough everything started after I installed the odd. Now it won't stop even without it. And no, I haven't damaged anything inside the laptop while I opent it (10 times++). I checked the sata cables and controller and the work in specs(voltage related). No dead circuits on the board no nothing, only a disconnected SD card reader left by me that way. Reconnected it, changed nothing.
I do mention I have the bluetooth and webcam disabled from bios since day 1 and didn't cause me no problems ever.

Darnassus
03-05-2016, 04:19 PM
Okay so just to bring it short..

Your two hard drives work fine, but the third one in the Caddy (CD tray) is too slow? 10mbs?

MaxCioco
03-05-2016, 05:26 PM
The ssd works fine. The hdd in the caddy works fine.
The hdd in the left slot works like cr@p.
Left as you look at it when the laptop is upside-down.

Worked bad before I changed the ssd, works bad after I reinstalled windows.
Note: the slot itself works bad. I pun both hdd's in it and they dont' work. I put them both in caddy, they work. With a adaptor to usb they both work.

From time to time the hdd will randomly go in to 100% usage and stops responding. If I try to access it, the file explorer won't respond anymore, and mostly my whole computer is frozen. Sometimes I have to restart to be able to use my laptop again.
As long as I don't use the hdd everything works just fine.

Tried to my old ssd in that slot. Same result.

So I get it that my sata controller is dead or what:))?

Darnassus
03-10-2016, 08:31 PM
I've no idea, that's a good question.. I must admit, my HDD is starting to feel a little slow too. It takes a while to read my download folder.

Have you ever disassembled your laptop (like I do a lot) before? IF so, there might've been some damage to the ribbon. Otherwise, I really cannot see what the problem may be in physical terms. Perhaps try giving the terminals a clean with some isopropyl alcohol to make sure the terminals are clean? Maybe some oil from your fingers might have caught on the pins.

MaxCioco
03-11-2016, 10:16 AM
Tried them all. And yes, I open it up quite often because it's a thermal compound assassin! I work with it in a server/silicon research/graphene printer/ room. If I don't re paste it all the time it would have been fried long time ago.

But, I know what I'm doing when I open it up. And yes, I do don't hurry when I do it; I work with patience.

And all the connectors are ok. (from the internal slots there is 1 ribbon going to the controller). I replaced the original cable with a "home made" connection, just for testing purposes. No change.

So, no damage to parts, no bad connectors/wires. I tested couple of integrated if they react properly, and the do. All that I can say now is that it's a software/integrated circuit problem, though I best bet is software. Because it worked for a time; time when nothing happened to the hardware.

I reached to the asus guys, and they said they never heard of it, and their only sugestion is changing the mobo. But, as the electrical connections are ok, they said only a new mobo could fix it, and warranty does not cover it sincer the current one is technically ok. So, I'm stuck with it like this for now.