PDA

View Full Version : Help - DVD Drive



jameskirl
12-26-2011, 09:37 PM
Need some help with my DVD Drive
G73JW - Slimline Type BD E DS4E1S

I don't normally use my optical drive and can't really remember the last time I used it.
Wanted to burn a DVD today but the DVD is not being recognised - just get the message "Insert a disc".
Listening to the drive it does spin up but the disc is not being recognised.

I tried a Music CD and Movie DVD and same result - nothing is recognised.

Also tried to uninstall the drive, rebooted and windows automatically reinstalled but same result - no discs recognised.

Any tips on what to do next?

Thanks in advance for the help.

dstrakele
12-27-2011, 02:09 AM
Does Windows Explorer fail to display files on a CD or DVD that has content written to it?

Or does Roxio CinePlayer fail to recognize the disk?

Does the solution in http://support.microsoft.com/kb/982116 resolve your issue?

Kipper
12-27-2011, 02:09 AM
download ImgBurn, its free

Tools, filter driver load order. capture the window and provide it in this thread.

Usually or at least sometimes it is a problem with upper filters and this will show us what you have on your system

PiaRowley
12-27-2011, 02:39 AM
capture the window and provide it in this thread.

http://www.jimjam.info/03.jpghttp://www.jimjam.info/14.jpg
http://www.bookunion.org/6.jpghttp://www.jimjam.info/jh3.jpg

jameskirl
12-27-2011, 03:03 PM
capture the window and provide it in this thread.

http://www.jimjam.info/03.jpghttp://www.jimjam.info/14.jpg
http://www.bookunion.org/6.jpghttp://www.jimjam.info/jh3.jpg

The issue is the entire drive. It is shown on WIndows Explorer but no discs are recognised whether DVD or CD.

When I insert a disc there is no prompt to open it. When I select the drive on explorer I get a message telling me to insert a disc even though a disc is already in there :(

Thanks for any help. I checked the microsoft link but no I don't have those KB errors.

http://i42.tinypic.com/2jcssg2.jpg

OlegLTS
02-05-2012, 09:22 PM
I have the same problem

TAAHMID
08-15-2012, 08:43 PM
Same problem here too !

cl-scott
08-15-2012, 09:17 PM
Have you tried deleting the upper and lower filters from the registry?

http://pcsupport.about.com/od/driverssupport/ht/upperfilters-lowerfilters.htm

DUST DEVIL
08-17-2012, 12:51 AM
download ImgBurn, its free

Tools, filter driver load order. capture the window and provide it in this thread.

Usually or at least sometimes it is a problem with upper filters and this will show us what you have on your system

Hi!

I have same problem. My drive worked perfectly but when I tried to copy DVD with Nero 10 something went wrong and now it's not working. I deleted UpperFilter (there was no LowerFilters) but still not working...

My computer: ASUS G74SX-1ATY

10912

Please help!