PDA

View Full Version : G73SW doesnt work after i punched it lol.



King_of_ROP
04-12-2016, 08:37 PM
Hi, like in the title, in a moment of anger i punched my laptop and now it doesnt work :P And i cant figure out what got broken, i was hoping you guys could help :)

Its a g73sw, and i hit it near the wasd area i think, so its somwhere where cpu might be i think.
I put it apart and took the CPU off but nothing anywhere was broken or cracked and no loose parts either.
When I power it up i get a plain blue screen, then an intel logo flashes in a corner of it then some strange shapes flash in the top and then it goes balck then it turns blue again and what is on it looks like windows loading bar, then it goes black and stays that way for ever.
Oh and also the power indication light never works. I cant figure out what is it :P
If its any help, recently I had to reset bios battery at daily basis(with holding down power button) because my graphics drivers kept constantly crashing otherwise.
And also I normaly use it without battery, which is in very poor state and can hardly keep the laptop up on its own for longer than 5 mins.

Thanks for all the help :)
Regards King XD

Black Phoenix
04-12-2016, 10:33 PM
Well....

Uhmmmm, You have the same symptoms that I had with my M51TR notebook, before he didn't boot anymore...

Mine started with the GBIT Network port never connecting in GBIT, only MBIT while taking between 5 to 10 min to get an IP (Even with fixed IPs taken the same time to connect);

Then Started to simply freeze in Windows, having to Force Shutdown.

Then one day never started again, Black Screen, no BIOS Logo.

King_of_ROP
04-19-2016, 03:50 AM
mmm no my sympthoms dont sound anything like what you described ;p

Also there is change, now it turns on and i can see bios logo isntead of intel and then i can see windows loading and i can even see the cursor in the end beofre the screen goes all blue, except all of these seem very disorted and low reslution like in movies and games when they show an old hardly working terminal :P
The power light is still off at all times.

Would that mean I damaged the GPU ? I dont think i hit the lapop anywhere near it, also it was rather a girly punch I am totaly surprised it broke at all :P