View Full Version : G752VY Sonic Studio II makes games crash

04-15-2016, 03:04 AM
The game Sleeping Dogs (available from Steam) crashes on load randomly and often if Sonic Studio is running in background in Windows tray. After you "Exit" SStudio (i.e.: SS2UILauncher.exe), the game will always load without crashes.

56886 56884

And here is the crash log pointing to a SStudio Launcher component (C:\Program Files\ASUSTeKcomputer.Inc\SS2\UserInterface\SS2OSD .dll):

Percorso dell'applicazione che ha generato l'errore: F:\SteamLibrary\steamapps\common\SleepingDogs\HKSh ip.exe

Firma del problema
Nome evento problema: APPCRASH
Nome applicazione: HKShip.exe
Versione applicazione:
Timestamp applicazione: 511151c4
Nome modulo con errori: SS2OSD.dll
Versione modulo con errori:
Timestamp modulo con errori: 55cd9503
Codice eccezione: c0000005
Offset eccezione: 00004f62
Versione SO: 10.0.10586.
ID impostazioni locali: 1040
Informazioni aggiuntive 1: bdcb
Ulteriori informazioni 2: bdcb33e65a9843796b7ec31cc25bda3b
Ulteriori informazioni 3: 28b9
Ulteriori informazioni 4: 28b92d9a58b4c3292e6786a4023b66af

04-16-2016, 08:07 AM
Hope ASUS will release a SStudio update soon fixing this bug too...
(Major bug here, settings not applied to speakers system-wide: https://rog.asus.com/forum/showthread.php?84506-G752VY-worst-audio-ever-from-speakers&p=587165#post587165 )

01-20-2017, 10:49 PM
Thank you very much, hexaae! :) My problems to launch two Origin games (Unravel and Sims 4) were driving me crazy. Removing Sonic Studio II from the tray has solved the problem. I have no problems with any of my Steam games though (Witcher 3, The Witness, Inside), they also work when SSII is running.

Does removing SSII reduce the sound quality while playing? When you play games, which device generates the sound in the G752VY? The Realtek IC or the Nvidia graphics cards?

01-21-2017, 11:53 AM
Honestly I would remove SStudio completely (read the whole thread I linked above in msg #2) and buy Hear by Prosoft (30 days trial if you want to test it).
SStudio totally sucks: adds more issues and doesn't do what is supposed to do, with poor final audio quality. It doesn't even work "system wide" but only with some software... Epic fail.
Uninstall it completely and use a much better (and working!) software Enhancer/equalizer...

01-21-2017, 03:31 PM
Same for Titanfall 2. No need to uninstall, just disable it in startup.

01-22-2017, 05:58 PM
I'll check that Hear audio software, it sounds great (pun intended). :D Definitely, ASUS made a mess with the audio of G752VY. In addition to the problems of Sonic Studio II, the right side of the computer gets hot when you listen sound through the internal speakers, as we are discussing in the thread https://rog.asus.com/forum/showthread.php?82619-G752-Audio-jack-area-too-hot. It's crazy that the thing that makes the case hotter is neither the CPU nor the GPU, but just some audio chip.

01-22-2017, 07:43 PM
Yes, known problem that one too...
As a personal experience with my (sold) G752VY Hear, or Razer Surround and other sound enhancer like them are 100 times better then buggy SStudio, which provides also a very poor sound quality honestly. Remove just SStudio and keep Realtek drivers, then install Hear, it was the best IMHO... worth the money to pull out a more than decent sound from a G752VY.

01-25-2017, 08:19 PM
By the way, my problems with Origin have gone far beyond not letting me launch some games. I've just discovered today that the reason why sometimes my computer couldn't properly wake up from sleep mode was... also Origin! A black screen forever, an irresponsive mouse after waking up, etc... All of these problems vanish if I don't let Origin run (neither at startup nor later).

01-26-2017, 12:15 AM
By the way, my problems with Origin have gone far beyond not letting me launch some games. I've just discovered today that the reason why sometimes my computer couldn't properly wake up from sleep mode was... also Origin! A black screen forever, an irresponsive mouse after waking up, etc... All of these problems vanish if I don't let Origin run (neither at startup nor later).
I doubt it. I've also had some issues in the past with Origin but current version has no issue when waking up from standby/hibernation (I'm one of the rare users who doesn't usually shut-down PCs but prefers sleep+hibernation). I have Origin always running in bg and sleep/hibernate at least 4 times a day without problems.

Must be a driver issue, and you have to find the culprit all alone since usually remote suggestions (last video driver, drivers from ASUS support site... etc.) won't help that much... There are other threads about wake-up issues with G752VY: search for them in the forum.

My hint is (as last chance) to take a look also at latest drivers from http://www.station-drivers.com/index.php?lang=en especially Intel/Chipset (and IME) category...
Some other links:

01-26-2017, 09:11 AM
I see a reason why blaming Origin makes sense. In the last weeks, when I pressed the restart button in Windows, Windows complained so often about Origin refusing to close, so Windows had to eventually kill the Origin process by itself. If a program refuses to be closed when Windows "nicely" requests it, then maybe its full state won't be properly saved into the SSD when getting into sleep mode. Hence, when you wake up later, maybe its former state won't be properly recovered (and it will make waking up crash). Does it make any sense?

If I do a clean boot (i.e. disabling all startup programs from the task manager, disabling all non-Windows services from msconfig, and then restarting), then waking up from sleep always works properly. It has been like this since I have the laptop: if the boot was clean, subsequent waking up operations never fail. So I guess blaming some program makes sense, right?

Well, I admit there is another possibility: waking up could work properly after a clean boot just because what matters is not what programs are running in the background, but how many programs you have in your background. If sleeping involves saving so many Mb into the SSD (and later waking up involves loading those Mb back), then maybe the chances to fail are higher. The bad news is that, if this were true, then it could be a hardware issue. But this could be consistent with those two threads you have linked.

I'll try to go into sleep mode while some game is running (e.g. I see that The Witcher 3 is using roughly 4Gb in run-time) and see if it works.

01-26-2017, 10:17 AM
I've tried what I said in the previous post. Windows correctly recovers from the sleep mode the full state of The Witcher 3 and Assassin's Creed: Syndicate (around 4 Gb run-time). So the amount of Mb to be saved into the SSD when you get into sleep mode doesn't seem to matter.

My current configuration is 100% services enabled, 100% startup programs disabled (except Steam). No waking up error so far.

By the way, I forgot to mention that, when I reported this waking up issue to ASUS, they recommended me to reinstall this driver:

http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin10/MEI/MEI_Intel_15M_Win10_64_VER11001169.zip?_ga=1.14923 9934.977153250.1483345790

Since waking up still crashed after reinstalling it and rebooting, I thought this driver didn't fix the problem. Shortly after that, I disabled Origin and everything started to work fine, so I credited the fix to disabling Origin. Not sure if that driver had anything to do with the fix.

01-26-2017, 12:16 PM
I'm so sorry to inform that my solution to solve the waking up issue doesn't work in all cases. :( I thought waking up after a clean boot was safe (25 waking up operations in the last 3 days, all correct!), but it isn't. After a clean boot, I started Steam and asked it to download some large game (10 Gb) into the SSD. After 5 Gb or so, when the right side of the case was already warm (yes, the right side gets warm even without any sound, just by downloading files), I put the laptop into sleep mode. 30 minutes later, when the right side of the case was cold again, I pressed the wake up button... and it failed. Two attempts. First time I could write my password but then I was stuck in the desktop. Second time I just got the infamous black screen.

Maybe reducing the number of running programs helps indeed, but it definitely sounds like a hardware issue.

01-27-2017, 12:35 AM
Mmmh, no. From all my long and accurate tests and the experience through years with various issues on 2 different G751JY and on G752VY I'd say it's just a HW/BIOS/driver issue if G752VY sometimes fails to wake-up... It's not a specific software, at least not directly, or this software (Origin f.e.) would manifest the same bugs also with completely different PCs.
Unfortunately ASUS support is totally inadequate, even for us luxury goods customers (IMHO is inacceptable we have the same treatment of a 300$ laptop, without a preferred channel) and rarely helps. Lucky enough my current G751JY came back from G-Sync Update Program (thank you ASUS in this case) with a better CPU (4860HQ) and USB 3.x ports on the left side perfectly working for me and never disconnecting anymore as it usually did (known issue, there's already another thread about this) with my original G751JY motherboard...

It's a pity, because with a little more efforts from ASUS it could really dominate the market with the best products in their category, if they fixed these annoying technical issues.

01-27-2017, 01:10 AM
Ok, following your suggestions, I have done the following changes:

- I've installed the lastest Intel drivers for the Chipset, the Management Engine, and the Rapid Storage Technology (downloaded from http://www.station-drivers.com/index.php?lang=en).

- In the BIOS, I've changed from Raid to AHCI, following the steps you explain in https://rog.asus.com/forum/showthread.php?84587-G752VY-issue-with-M-2-speed-after-resume-from-sleep&p=588732&viewfull=1#post588732.

Then I've repeated the experiment of downloading a big file for 30 minutes, next suspending without previously stopping the download, and finally resuming 30 minutes later. The computer has woken up correctly.

I don't want to be overoptimistic (again!), but it sounds good so far...

01-27-2017, 10:29 AM
So far so good, it seems that it worked! Moreover, I also experienced that halved transfer rate problem, and now it's gone. Grazie mille, hexaae! :D +1 reputation.

Yes, it's crazy that ASUS doesn't polish their high-end products a little bit more before selling them. How many hours have users lost in this forum, suffering their computers instead of enjoying them? Users shouldn't have to spend their time fighting against drivers and the BIOS...

01-27-2017, 12:13 PM
Great! I'm glad I could help! :)

01-27-2017, 03:08 PM
By the way, do you know why, after this change, rebooting takes a much longer time than before? Now I have 15-45 seconds of black screen until the Republic of Gamers logo appears again. Starting the computer and waking up from suspension are as fast as always, only rebooting is slower.

I've checked that fast boot in enabled in the BIOS.

01-27-2017, 06:36 PM
Please, open another topic about this other issue...
Do you have latest BIOS from http://www.asus.com/Notebooks/ROG-G752VY/HelpDesk_Download/ ? AFICR this was somewhat fixed by latest BIOS

01-27-2017, 11:10 PM
My BIOS version is 213.

The problem happened a few hours ago, but It's not happening now. If it happens again then I'll open a new thread about it...

01-28-2017, 01:20 AM
I tried to replicate the things I was doing when rebooting was so slow, but the problem has not happened anymore. Rebooting is fast again, less than 10 seconds. But I have not changed any configuration settings or drivers to fix it, I just increased the amount of free space in C: (the SSD, the booting drive) from 25Gb to 50Gb. I wonder if this could have anything to do.

01-28-2017, 07:25 PM
As far as I've understood reading some tech blogs recently it seems with current builds of Windows 10 you can leave Defrag ON (Auto every week): on SSD systems IT WON'T defrag the SSD but will call the TRIM command properly. This can help keeping good transfer performance.
There was a time when Defrag was better to be set OFF with SSDs, but more recent builds of Windows 10 changed again behavior....

01-28-2017, 09:17 PM
It would be very interesting to know if starting to run out of free space in the SSD (e.g. having less than 25Gb) may have such a big impact on delaying reboots. If so, it would also be interesting to know if trimming the SSD from time to time would reduce that impact.

If I observe anything confirming/refuting this theory, I'll report it here. I'm curious.

02-03-2017, 10:25 AM
For future readers switching to AHCI from Raid: I can confirm that the amount of free space in C: had nothing to do with my reboot issue. Just to learn, I reverted the change (i.e. I came back to Raid) and then I repeated the process to come back to AHCI again. Again, the first 4-5 reboots were very slow. And again, they magically began to work properly afterwards, though I didn't free any additional space in C:. It seems that, when I change from Raid to AHCI, some things take some time to "settle". Maybe some Windows configuration silently changes after a few reboots, I don't know.

By the way, since Rapid Storage Technology is useless if you are not using Raid, installing it should be pointless after switching to AHCI, I guess. I also installed it because I thought it would have something to do, but it shouldn't (currently uninstalled and everything is Ok).