PDA

View Full Version : G75VW Weird screen flicker & GPU behavior [help]



DjDannyD
04-30-2016, 05:22 PM
Hello!

I have been experiencing the same screen flicker for some time now. Recently, I looked into what might be causing it, but I couldn't conclude on anything. There were some anomalies with the GPU's clock while the flickering was happening, so there might be a connection there, but I am not competent enough myself to make that connection.

This behavior manifests itself either when the system is first started (or awakened from sleep/hibernation) and sometimes when I launch a game, there's a screenshot to reflect both. If I have a second monitor connect, sometimes the visual flicker happens on the other screen (Note: It's always on only one or the other, never both). I have included below some screenshots of Afterburner open showing the aforementioned behavior, a video of the flicker in question and an Afterburner history log file, in case that is helpful.

To give some info on the system, I am running a 64 bit Windows 10 on a G75VW, installed on a 250GB Samsung 840 EVO SSD *Samsung Magician is installed* and using the stock HDD (ST750LX003-1AC154) as a media drive. Should be a default setup, but just in case; the GPU is a GTX 670 (3GB VRAM), CPU is a i7-3610QM chip @ 2.3 (before turbo boost) and 16GB of RAM. I rarely overclock the GPU and if I do, it's in line with some of the guides I've read here, max of 700MHz Core Clock and 1750MHz Mem Clock.

Screenshots:
57196
[This was just after a fresh system start, notice the graph.]

57197
[In this instance, I've started a game, the clock speed behaves the same and it directly affects the game's FPS (notice FPS graph in top right, next to mini-map)

Video :

https://onedrive.live.com/redir?resid=E92427691C39599C!38786&authkey=!AGzbgomjhUM2rr0&ithint=video%2cmp4

Thank you for your time and I hope someone has ran into this before and can advise me as to how to handle it.
~Danny

EDIT: Forgot to mention drives.

DjDannyD
05-03-2016, 08:42 PM
Additional notes that might be of worth mentioning:
I've kept the fans and the computer in general clean thoroughly and regularly.
Updated drivers where possible.
Installed windows fresh a couple of times.

None of the above has prevented/stopped the flickering to occur on boot-up when an external monitor is connected.

0neWinged
06-11-2016, 06:20 PM
I had a very similar problem with my G75vw that I was able to fix. Well at least the screen flickering part. So give this a try, couldn't hurt.
Right click and open NVIDIA Control panel.
Click on "Change Resolution" on the left panel.
Click customize button.
New window will pop up, click "create custom resolution" button.
Make sure resolution is 1920x1080
Change the refresh rate to "64"
Scan type progressive.
Click test, then ok. (Screen flicker should be gone)

Pictures added for reference.