View Full Version : Set up G752 ROG MacroKey to Turn off Screen Instead of using (FN + F7) ?

05-03-2016, 05:41 PM
Instead of hitting two keys (FN + F7) to turn off the screen, I would like to just hit the M5-key.
So I try to use the Set Macro on the M5-key to turn off the screen, but for whatever reason I don't seem to get it to register the FN + F7 combination.
All drivers and BIOS are up-to-date as listed on the ASUS download page.

Anybody have any idea of how to do this - or is there any other way to make M5 turn off the screen?

05-05-2016, 01:11 AM
A. You can config any macrokey to run any exe/file you wish using "ASUS ROG MacroKey" config app.
B. you can use this app for the 'screen sleep'. (http://www.thewindowsclub.com/screenoff-turn-off-windows-laptop-screen) (it might "jump" your Antivirus app... it is false-positive and you should exclude it in them. I trust that source site ).
C. Profit.

05-05-2016, 04:34 PM
Thanks Gps3dx - for that EXCELLENT suggestion!

Here is what I did:
1) Downloaded and installed the ScreenOFF2.
2) EXCLUDED the ScreenOFF2 folder from Windows Defender (the only AV software I use).
3) Launched ROG MacroKey and set the M5-key to launch ScreenOFF2.

Thereafter, when hitting the M5-key, the screen shuts off. BEAUTIFUL!!!

However, I have noticed that when I have SKYPE open, hitting the M5-key only works once.
Thereafter, hitting the M5-key does not seem to have any effect.
Even if I try to run the ScreenOFF2 program by itself now - nothing happens.

Only after I shut down SKYPE, and WAIT FOR ABOUT 30 seconds... then the M5-key works normally again, and also running the ScreenOFF2 program itself, now again works normal.
Within SKYPE, there are settings for hotkeys, but all those are turned off, no hotkeys in effect within SKYPE.
I also tried to exclude the SKYPE folder entirely in Windows Defender, but no difference.

I run Windows 10 Pro-64.
Not sure if this problem is only connected to SKYPE, but so far it is the only program I have found that makes the M5-key not work.

05-05-2016, 06:52 PM
On my G751JT I got only m1-3 keys.
opening skype didn't matter the rebinds I made, it works just fine.

Try to remap another M-key with ScreenOFF2.
Try to use other "ASUS ROG MacroKey" app version ( older/newer ).... I use v10029.

also, when Skype is working... open task manager and see if you got "HID.exe" running... if so, kill this process, and run it again from "C:\Program Files (x86)\ASUS\ASUS ROG MacroKey" ( that's the default installation folder ).... then try to press M5 again.

05-06-2016, 01:59 AM
Thanks Gps3dx for your suggestions!
I tried to connect other M-keys to ScreenOFF2, but with same result as M5-key described above.

Also, my version of ASUS ROG MacroKey is 1.04 (newest version).
I uninstalled it and tried older version 1.03 - same result.
I also tried an older version of SKYPE, but with same result.

I further did a search on the full PC for "HID.exe" - but did not find it.

Very strange, indeed.
What is also weird, is that after I close down SKYPE, it takes pretty much 30 seconds until everything goes back to normal, and I again can use the M5-key or even execute the ScreenOFF2 by itself.....