PDA

View Full Version : ROG Game First III Network Enhancer is causing performance issues with Overwatch



jgilbertson
05-04-2016, 04:07 PM
Currently seeing an issue with GameFirst III and Overwatch.
Basically while running Game First III with default settings performance will be poor and you can view users teleporting around during gameplay. Users may also view you teleporting around as they will have trouble engaging you during the game.

1. Setup a PC that uses an ASUS RoG(Republic of Gaming) Motherboard that will support the Game First III software. MOBO tested was a Maximus IV Gene-Z
2. Install all drivers, including the GameFirst III software.
3. Restart the PC and ensure that the software is running at default values and switch the mode to Game. Overwatch should be labled with a "Normal" value.
4. Install and run Overwatch
5. Ensure that the Network indicators are enabled and load into a Quick Match.
6. Once in the match, play as normal and keep an eye on the PNG, RTT, and IND.


Additional Info: When switching the value to "High" or "Highest" the title performs as expected for the PC build and network stability is intact.
Also, when in the "Optimized" mode, the network performance does not appear to be affected.

dianebrat
05-05-2016, 11:46 AM
Game First causing issues is nothing new, the usual recommendation is to uninstall it.

m33ts4k0z
05-08-2016, 05:49 PM
I didn't have this issue while I was downloading from Steam and playing Overwatch at the same time about an hour ago. Steam needs to be on normal and overwatch on highest priority. This is normal because GFIII's database isn't updated with this game so it doesn't "know" that its a game.

FalloutBoy
07-15-2019, 09:55 AM
I have a ROG Zenith Alpha with a 2950x I installed the game first drivers off of the supplied USB stick and then after reboot checked for an update - which there was, I applied the update and rebooted and thought nothing more of it barring the fact that I started having page resolving errors without any specific reason, the connection was good and my X399 Prime A was getting though first time.

So I tried a restart at which point the boot cycle stopped at CPU 0D - when I looked this up it says "Reserved for future AMI SEC error codes".

Confused I pulled the mains cable and waited 30 seconds, plugged back in and all booted up fine, so I tried another restart and again the boot cycle stopped at CPU 0D I pulled the mains again waited 30 seconds, plugged it back in and it came on first time. The only change I had made was the install and upgrade of the ROG First software and thus although it seemed highly illogical I uninstalled it.

I have now done four successive restarts with no problem, put the computer to sleep with no problem, powered it on and powered it off - no problem could the ROG game first software cause this sort of issue it seems truly out there as it's only meant to optimize network traffic based on a user choice how the hell would it effect the CPU on a warm start?