View Full Version : G750JX won't boot

05-04-2016, 07:25 PM

Specs: Asus G750JX,
intern 500 GB SSD
Nvidia Geforce GTX 770M
8 GB Ram

So here is the problem. One day I came back from school and I started my Laptop but suddenly a blackscreen appeared and
said: "no bootable device insert boot disk and press any key". I restarted my Laptop many times but the it always says
the same. So I tried to go inside the BIOS and realized that there were no Boot options available. I searched through a lot forums
, but found nothing. I tried reseting my Settings or using CMS but nothing worked. After that i tried installing WIN 10 new from a USB,
thats the point where I found out that only my HDD is still working/detected. I tried switching the HDD or my SSD but still didn't work.

I hope somebody can help me with this because i need my laptop as fast as possible back. I've been working on stuff for a wedding which is in a week.
Thanks in advance.

05-04-2016, 08:21 PM
Can you let us know what brand/model is your SSD and how long have you been using it? Also, is it the one that came with your notebook?

05-04-2016, 08:34 PM
I have a intern SSD (don't know the Brand). And I also build in an SSD (A Sandisk Extreme Pro SSD which I had for 2 years now).
And it's both SSDs (and just the SSDs) that won't get recognized.

05-05-2016, 02:23 AM
Okay, did you update something recently? Like a BIOS update? If possible could you take a picture of the boot options on your BIOS?

05-05-2016, 06:42 AM
Actually yes I had some problems with my fans not getting high enough and just force shutting down when it got hot enough. I heard you can resolve this problem by updating the version (206). But I couldn't because my bios was already on the newest bios. Technically i didn't update the BIOS it just said: "the installed version is newer.".
And the only thing in my boot options are my USBs and my Matshiba BD Player (when I enable CSM).