PDA

View Full Version : Asus G75VW Not Turning On Problem



nikolajsvv14
05-24-2016, 03:06 AM
About a month ago my laptop randomly shut off and wouldn't turn on again. When I would try to turn it on the LCD lights on the front would come on, but that's it. Also there was absolutely no sound from the computer itself.

Today I tried turning it on again and something weird happened. Right away I heard a "eeeeee" sound and I took out the battery. I tried it again and it turned on for the first time, but suddenly turned off again. I'll make a more easy to follow thing below...



Laptop: Asus G75VWhttps://www.asus.com/us/ROG-Republic-Of-Gamers/ROG-G75VW/]
https://www.asus.com/us/ROG-Republic-Of-Gamers/ROG-G75VW/ (http://[url)

Initial issue: Shut off randomly while checking emails, wouldn't turn on (other than the 2 LCD lights at front)

Fixing Attempt: I reset the RAM and Hard drives. I also took out the CMOS battery for 5 minutes. [Didn't fix issue\

Other things: Today when I tried turning it on there was a slight smell of burning.

Screen display when it finally turned on [shut off couple seconds later]:
https://i.gyazo.com/9be211439821b892f84ac17cb60de738.jpg

nikolajsvv14
05-25-2016, 02:11 AM
Bump

Almighty1
06-13-2016, 08:23 AM
Try another AC adaptor that is compatible with the system.

ROG_HARDCORE
06-13-2016, 09:28 AM
This might be the issues with the GPU.

0neWinged
06-13-2016, 09:48 AM
Yea I agree, could possibly be GPU failing. when its under load and gets some temp, could cause shutdown without being able to turn back on. When fully cooled and if GPU hasnt completely failed yet, it may turn back on for a short amount of time.
Did you ever experience any flickering or lines?
possible it could be AC, but doubful as it should still turn on by battery power.

May have a 660m GPU going up on ebay here soon.

Almighty1
06-13-2016, 10:00 AM
The problem is he didn't say if he had any battery power left.