PDA

View Full Version : G75V Shaking white screen with vertical grey lines when gaming, HDMI output is fine



Nem3sis
06-05-2016, 02:31 PM
Hey guys,

I have the following problem: I can use the laptop for hours reading, working on word files, editing powerpoints, etc. but whenever I start a game or a movie,
a few minutes into it (or sometimes from the very start) the screen gets all shaky, all or almost all image is lost and it becomes white with grey vertical
lines. Then, if I reboot, from the very start (Rog logo, bios, etc.) it's the same - shaky, unstable images, white and grey vertical lines. If I turn it off for
a few hours it's fine, again only until I start a game or a movie.

I tried gaming / watching movies by connecting it via HDMI cable - no problem with the video output, hours later. I opened the laptop and cleaned the connections:
1. Between the LCD cable and the screen
2. Between the LCD cable and the motherboard/graphics card
This lead to no improvement. Again, if I decide to play games/movies on the main screen, a few minutes later I get the same problem occurs.

What I presume from here is the following (and please correct me if I'm wrong):
1. The graphics card and motherboard should be fine (I could game on the TV via HDMI connection)
2. The problem is either in the LCD video cable or the screen

My question for you guys is the following, how can I check which one of the two is faulty - the LCD video cable or the screen?
Where would you recommend I order the spare parts from? Any links (if necessary send them as a PM)?

Thanks a lot!

Clintlgm
06-05-2016, 02:52 PM
Well the cheapest route would be to change out the Video cable. it that doesn't' fix it you could try a screen, still could be a Motherboard connection issue, with out having spare parts around it could get expensive trying out parts. I would look on Ebay for parts there is a EU parts connection. if you goggle Asus G75VW or VX whichever you have? Parts it should come up.