PDA

View Full Version : AI Suite 3 - cannot find a download link for my mobo



ckbeme
06-27-2016, 08:03 PM
Greetings all,

This is my first post on here. I've been like thousands of others the past couple of months... trying to find where to d/l AI Suite 3. I contacted ASUS support and they
just gave me a link to FAQ where I could verify that my MOBO was Windows 10 ready. I had already done that, and had spent hours searching the ASUS site and
the web. I know you have to download the correct version of AI Suite 3 or it won't work on your MOBO. I've seen several posts on the other 2 ASUS forums where
people that have older MOBO than mine have gotten the AI Suite 3 for their MOBO. So, does anybody on here know how to find the correct version for your board?
When I go into ASUS support and click on my OS, then Drivers and Tools, I get BIOS, SATA,Audio, and LAN. I was told by ASUS this is where AI Suite 3 should be for
my board.
Well, it's not. I find it hard to believe there isn't a version for my MOBO. I have a M5A99FX PRO R2.0 Motherboard, purchased in Feb 2015.

I'd really like to get a copy of it because I'm not happy with the performance of certain parts of my system. I have to hope the new AI Suite will help improve the
performance.

I had no luck on the other 2 forums, and I thought you guys are probably more likely to know than the folks on the other 2 forums. I'd appreciate any help. Surely
someone on here has the same board as mine and they have found the download.

Thanks all for any help.

Ck

toronto699
06-27-2016, 10:39 PM
here but its Ai Suite 2 in W8.1
http://support.asus.com.cn/Download.aspx?SLanguage=en&m=M5A99FX+PRO+R2.0&p=1&s=24

ASUS-OP
06-27-2016, 11:50 PM
Hi ckbeme, welcome to the ROG Forum.

Unfortunately your motherboard is based on AiSuite II design, which the software has discontinued and moved onto the new AiSuite 3, which is a completely new written software package that won't install on your board.
The Windows 10 support for older generation design motherboards feature only driver support excluding applications.

I will suggest to try installing AiSuite II for Windows 8.1 under compatible mode to see if that works, as in many cases most modules do work.
Let us know how it goes, and we will try to help in the best we can from there.

ckbeme
08-11-2016, 04:35 PM
Hi,
Thanks for getting back to me. I thought I had notifications on, but I guess not.
That really pisses me off. My board isn't THAT old. The main reason I wanted it was for the USB Boost. Have any of you tried it? I'm about to buy a new drive, and I'm
thinking about the USB 3.1 or maybe even 3.2.
But if ASUS is going to make that USB boost available for my board, do you think I could get by with a PCI card that runs at 3.1?
I use external USB a lot - for extra storage and backups.

Has anyone on here tried the suggestion - Run AI Suite for Win 8.1? And actually, does it even have USB Boost?

Thanks, all.

ckbeme